1 2 Previous Next 18 Replies Latest reply: May 20, 2013 8:19 AM by Jan Vervecken Go to original post RSS
      • 15. Re: 11.1.2.4.0 : Java version 1.6.0_24 not supported. ... required is 1.6.0_35
        Timo Hahn
        Oh, I see the problem (may be).
        Once you build the default domain the path to the jdk is hard coded into the setDomainEnv.sh (or setDomainEnv.cmd). To run the integrated wls using another jdk you have to edit this file. It's found under <path to your systemfolder>\system11.1.2.4.39.64.36\DefaultDomain\bin folder. In the file change the property
        set SUN_JAVA_HOME=C:\Program Files\Java\jdk1.6.0_45
        If you use the generic installer (like I did) and point to the other JDK it sets this property right to the jdk you used when creating the default domain.

        By the way, when you start the integrated wls you get the jdk version it's running on on the log window:
        starting weblogic with Java version:
        java version "1.6.0_45"
        Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
        Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)
        if I run using JDK 1.7 i get
        java version "1.7.0_21"
        Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
        Java HotSpot(TM) Client VM (build 23.21-b01, mixed mode, sharing)
        Timo

        Timo
        • 16. Re: 11.1.2.4.0 : Java version 1.6.0_24 not supported. ... required is 1.6.0_35
          Jan Vervecken
          Thanks for your reply Timo.
          Timo Hahn wrote:
          Oh, I see the problem (may be). ...
          Not sure if there is really a problem. That is why I posted some details about the behavour I see and asked about intended behaviour.
          ... If you use the generic installer (like I did) and point to the other JDK it sets this property right to the jdk you used when creating the default domain. ...
          Well, I used "Studio Edition 11.1.2.4.0 Windows Install ( jdevstudio11124install.exe ) " which seems to behave somewhat different when creating the domain for the "IntegratedWebLogicServer" in JDeveloper.
          ... By the way, when you start the integrated wls you get the jdk version it's running on on the log window: ...
          Sure, but being able to see Java System properties using WebLogic Server console provides more flexibility (on any WebLogic Server installation, or to get different property values).
          ... if I run using JDK 1.7 i get
          java version "1.7.0_21"
          Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
          Java HotSpot(TM) Client VM (build 23.21-b01, mixed mode, sharing)
          Thanks for the confirmation.

          regards
          Jan
          • 17. Re: 11.1.2.4.0 : Java version 1.6.0_24 not supported. ... required is 1.6.0_35
            Brian Fry-Oracle
            Thanks for reporting this. This was an oversight on our part.

            Just a quick recap for anyone who may stumble on this post later. In JDeveloper 11.1.2.4.0, we bundle JDK 1.6 update 24 in the platform-specific installers (jdevstudio11124install.exe and jdevstudio11124install.bin). We had originally planned to uptake and include a more recent JDK 1.6 version as part of the 11.1.2.4.0 release, but due to reasons I will not go into here, we were unable to do so. However, we had already started to change some of the UI (specifically the error message you get on startup if using an unsupported JDK version) based on the presumed updated JDK version, and we neglected to back out that UI change.

            So, the upshot is that JDK 1.6 update 24 is the minimum required release for 11.1.2.4.0. The error message saying otherwise is our mistake. Needless to say, it's rather embarrassing, and we intend to fix this as soon as we can. In the next couple of days, we plan to post an updated 11.1.2.4.0 release with this code reverting to displaying an error only for JDK versions earlier than 1.6 update 24.

            What do you need to do? If you are not seeing the error (because you are using JDK 1.6 update 35 or later or you are on a non-Windows platform), you do not need to make any changes. If, however, you are seeing this error and you want it to go away, you can either install a JDK 1.6 update 35 or later (instructions on how to do so are captured later in this thread) or you can re-download and re-install JDeveloper a few days from now when we release the update. In that update the only included bug fix will be to modify the condition in which the error is reported. There will not be a corresponding updated ADF version, as this issue applies only to the JDeveloper launcher code on Windows.

            We apologize for the confusion, and thank you for your continued support.

            -- Brian
            • 18. Re: 11.1.2.4.0 : Java version 1.6.0_24 not supported. ... required is 1.6.0_35
              Jan Vervecken
              Thanks for your reply Brian.
              Brian Fry wrote:
              ... This was an oversight on our part. ...
              Thank you for the confirmation.
              ... or you can re-download and re-install JDeveloper a few days from now when we release the update. ...
              This is what I did, and I no longer got messages about the Java version.

              about, before ...
              Oracle JDeveloper 11g Release 2 11.1.2.4.0
              Studio Edition Version 11.1.2.4.0
              Build JDEVADF_11.1.2.4.0_GENERIC_130421.1600.6436
              Copyright © 1997, 2013 Oracle and/or its affiliates. All rights reserved.
              IDE Version: 11.1.2.4.39.64.36
              Product ID: oracle.jdeveloper
              Product Version: 11.1.2.4.39.64.36
              ... and after ...
              Oracle JDeveloper 11g Release 2 11.1.2.4.0
              Studio Edition Version 11.1.2.4.0
              Build JDEVADF_11.1.2.4.0_GENERIC_130421.1600.6436.1
              Copyright © 1997, 2013 Oracle and/or its affiliates. All rights reserved.
              IDE Version: 11.1.2.4.39.64.36.1
              Product ID: oracle.jdeveloper
              Product Version: 11.1.2.4.39.64.36.1
              regards
              Jan
              1 2 Previous Next