4 Replies Latest reply: May 29, 2013 2:00 PM by 1011702 RSS

    Issue with UI of CKEditor when editing asset in Form Mode.

    Kinjal Gala
      Hi,

      There are two icons of CKEditor: Add asset link and Include Asset.

      I have successfully enabled them in web mode but not able to enable them in form mode.

      I have referred First Site II for the same but still facing this issue.

      Please let me know how to enable these two icons in Form mode under Edit option.
        • 1. Re: Issue with UI of CKEditor when editing asset in Form Mode.
          rsriram
          Hi:

          What is the attribute editor assigned to this attribute? Can you post the XML here.

          Thanks

          Ram Sriram
          • 2. Re: Issue with UI of CKEditor when editing asset in Form Mode.
            Kinjal Gala
            I will share my CKEditor's xml file. But it won't be of any help. As I have just referred to FirstSiteII site's CKEditor's xml file and followed steps as they have. None of the Attribute Editors in FirstSiteII site include line that talks about Linking of Assets.

            <?XML VERSION="1.0"?>
            <PRESENTATIONOBJECT NAME="ckeditor">
            <CKEDITOR WIDTH="500px" HEIGHT="300px" IMAGEPICKERID="1112668339899" PICKASSETID="1112471922467" />
            </PRESENTATIONOBJECT>
            • 3. Re: Issue with UI of CKEditor when editing asset in Form Mode.
              rsriram
              Hi Kinjal:

              I am going to point you in the right direction and hoping you can figure it out.

              1. In the developer guide search for "CKEditor Example" and understand configuration options for CKEditor.

              2. Open file C:\YOURPATH\Sites\11gR1_BP1\Sites\11.1.1.6.1\presentationobject.dtd and see options for CKEditor

              3. Open file C:\YOURPATH\Sites\11gR1_BP1\App_Server\apache-tomcat-6.0.32\webapps\cs\ckeditor\config.js and understand the concept of toolbars. You will find that valid values of TOOLBAR are

              Default, FWToolbar,CS,SITES,SITES_WEB,SITES_WEB_SIMPLE etc. You can create a custom toolbar if you wish

              4. Here is a sample XML configuration below. Try changing value of TOOBAR to one of the above.

              <?XML VERSION="1.0"?>
              <!DOCTYPE PRESENTATIONOBJECT SYSTEM "presentationobject.dtd">
              <PRESENTATIONOBJECT NAME="CKEditor"><CKEDITOR WIDTH="600" HEIGHT="150" TOOLBAR="Basic" IMAGEPICKERID="<<<ID>>> " ></CKEDITOR></PRESENTATIONOBJECT>


              Let me know how it goes.

              Thanks

              Ram Sriram
              • 4. Re: Issue with UI of CKEditor when editing asset in Form Mode.
                1011702
                Hopefully this will help someone else down the road. What I found was missing is to my ckeditor config file I had to add the following:

                config.enableEmbeddedLinks = true;

                Once I added that in then the asset links became active in form mode.

                -Bryan