3 Replies Latest reply: May 8, 2013 4:44 PM by Cindys-Oracle RSS

    Mount Point /home

    1502
      For Solaris 10, I created a separate VDI disk for /home. I would like to use this same disk for Solaris 11. Do you know how to turn off all the auto-home stuff so I can use /home as a mount point?
        • 1. Re: Mount Point /home
          Dave Miner-Oracle
          All you should need to do is comment out the /home line in /etc/auto_master and restart the autofs service.
          • 2. Re: Mount Point /home
            Cindys-Oracle
            Hi--

            We seem to have some challenges in disabling the auto home behavior so I will look into it.
            The only way I was able to modify /home was to disable autofs and I don't think this is a good answer.

            I noticed that autofs is also controlling /home in current Solaris 10 releases so I would suggest that
            you consider using something like /export/home/vdi or /home2/vdi instead.

            I'm unclear what other features might be depending /home being automounted but this service
            is setup by default so consider using an alternate mount point.

            Thanks, Cindy
            • 3. Re: Mount Point /home
              Cindys-Oracle
              I have found some more info that makes the following steps work on one of my S11.1 systems but not on the other S11.1 system and they are configured identically. Can't figure it out. Maybe someone else can comment. Here are the steps:

              1. I don't know if this matters but would be worth checking to see that the automount is set to files. It is by default.

              # grep automount /etc/nsswitch.conf
              automount: files ldap

              2. Disable the /home entry in /etc/auto_master and also move the +auto_master entry to the end of the file, like this:

              /net -hosts -nosuid,nobrowse
              #/home auto_home -nobrowse
              /nfs4 -fedfs -ro,nosuid,nobrowse
              +auto_master

              3. Refresh the autofs service instance:

              # svcadm refresh svc:/system/filesystem/autofs:default

              4. Test that the /home mountpoint is available:

              # mkdir /home/test

              Thanks, Cindy