10 Replies Latest reply on May 11, 2013 11:13 AM by user13295824

    JDeveloper does not communicate successfully with Weblogic inside Oracle VM

      Hi there,

      I have Oracle Weblogic with Oracle SOA suite 11 g installed in Oracle VM running at localhost. I have the JDeveloper ( installed ob local machine (Not inside Oracle VM).

      JDeveloper is unable to communicate successfully with the Weblogic instance inside VM. The resulting message is as under.

      Testing JSR-160 Runtime ... failed.
      Cannot establish connection.
      Testing JSR-160 DomainRuntime ... skipped.
      Testing JSR-88 ... skipped.
      Testing JSR-88-LOCAL ... skipped.
      Testing JNDI ... skipped.
      Testing JSR-160 Edit ... skipped.
      Testing HTTP ... success.
      Testing Server MBeans Model ... skipped.
      Testing HTTP Authentication ... success.

      2 of 9 tests successful.

      However the JDeveloper instance installed inside the VM is connecting to the weblogic successfully. I can access EM and weblogic console of the weblogic from internet explorer of host machine.

      Your step by step help instructions shall be really appreciated.

      I did search for the error messages, tried the proxy changes and found no proxy mentioned on my machine; neither in JDeveloper nor in Browser.

      Tried with windows firewall turned off on the host machine. No luck.
      Tried with Firewall of Linux in VM turned off and no luck.
      Tried couple of other threads already available but no luck as those do not provide solution e.g. Failed to connect WebLogic Application Server