3 Replies Latest reply: May 13, 2013 3:34 AM by Veeresh Rayan RSS

    Informatica Integration Service - No Code Page Error

    715200
      Hi All,

      I have installed Informatica 9.1.0 downloaded from Oracle E delivery. Server installation is completed without any errors or warnings.

      In Admin Console I created Repository Service which created and running fine.

      But when I create Integration Service It fails to start up with Code Page error. In General Properties when I drop down Code Page for selecting the code page, that drop down is empty.

      I created env variables also namely LANG = us_UTF8, LC_ALL = us_UTF8 , INFA_CODEPAGENAME = UTF8. Also repository service is running on UTF8 Code Page. Underlying Data base NLS_LANG = UTF8

      Is there a way to set code page and make Informatica services up and running.

      Thanks In Advance,

      Ankit Rana
        • 1. Re: Informatica Integration Service - No Code Page Error
          Veeresh Rayan
          Looks like Installation Code page & Repository Code page is different in your senario.

          Check both the code page if different then make it to same.

          click on your integration service in domain navigator
          ; click on processes on the right hand side
          ; under processes click on the node ( NOT the link where it says node) ...
          .you will see the service properties , edit the service properties and change the code page to ms windows

          Mark correct or helpful if it helps,

          Regards,
          Veeresh Rayan
          • 2. Re: Informatica Integration Service - No Code Page Error
            715200
            Hi Veeresh,

            The code page is not available, the Drop down for code page is EMPTY. That is my issue. Not code page is different.

            Thanks in advance.

            Ankit
            • 3. Re: Informatica Integration Service - No Code Page Error
              Veeresh Rayan
              Can you try to delete the repository and recreate it ?..And then try to create integration service as well??..

              Let me know the results.

              Also you need to set NLS_LANG parameter.

              To set the NLS_LANG environment variable for Oracle databases
              1. Determine the NLS_LANG value.
              a. In the data warehouse database, run the following command:
              SELECT * FROM V$NLS_PARAMETERS
              b. Make a note of the NLS_LANG value, which is in the format [NLS_
              LANGUAGE]_[NLS_TERRITORY].[NLS_CHARACTERSET].
              For example: American_America.UTF8
              2. For Windows:
              a. Navigate to Control Panel > System and click the Advanced tab. Click
              Environment Variables.
              b. In System variables section, click New.
              c. In the Variable Name field, enter NLS_LANG.
              d.In the Variable Value field, enter the NLS_LANG value that was returned in
              Step 1.

              The format for the NLS_LANG value should be [NLS_LANGUAGE]_[NLS_
              TERRITORY].[NLS_CHARACTERSET].
              For example: American_America.UTF8.

              Mark correct or helpful if it helps,

              Regards,
              Veeresh Rayan