14 Replies Latest reply: May 14, 2013 4:23 AM by Vijaya Moderator -Oracle RSS

    message loading with rotating ring

    Masood
      Hello
      I deployed my test application successfully on managed server found in weblogic server 10.3.5 through jdeveloper 11.1.1.5
      Now to open the enterprise application i run the following url in internet explorer or in google chrome then I just see the message as loading..... with a rotating ring and nothing appears.

      http://192.168.100.4:7003/MyDemo/faces/MyDemo.jsp

      Can anybody tell me where I have to fine tune or change configuration in weblogic server or elsewhere.

      Your help will really let me go ahead.
      Regards,
      Masood
        • 1. Re: message loading with rotating ring
          Vijaya Moderator -Oracle
          Hi Masood,

          Please answer to the below questions and also try the action plans.

          1. Was the same application tested duly in the integrated weblogic server in Jdeveloper?

          2. Is the application accessible when deployed on to the Admin server in the standalone environment?

          3. Did you access the admin console and check the deployment status of your application?

          4. If it worked fine, did you retarget the ADF libraries to the managed servers, before deploying the ADF application to the managed Servers?

          5. When you see the application doesn't load on the browser, did you see any errors in the server console where you started the weblogic server?

          6. If you still see no error, Please go ahead and enable the deployment debug flag from Admin console and redeploy the application and let us know the results of all the above action plans?


          Thanks,
          Vijaya
          • 2. Re: message loading with rotating ring
            Masood
            Hi Vijaya
            1. Yes, It is tested in IntegragtedWebLogic Server by jdeveloper. It loads on browser and displays data.
            2. Even if it is deployed on Admin Server, it is not accessible. It shows the same message as loading........
            3. I accessed the admin console and checked the status. It is active and healthy as well.
            4. It didn't retarget the ADF libraries. The point is not clear to me.
            5. I didn't see any errors in the server console.
            6. If I am not mistaking, you are talking about adminconsole/servers/managed server(ADFServer)/debug/weblogic/enable. I
            did it and I was forced to restart my server and after that I redeployed it again. But I didn't find anything to trace on.
            If possible please explain again the 6th point.
            The status is same as it was. message loading.....with a ratating ring.
            Also due to 6th point my server has slowed down.
            Regards,
            Masood
            • 3. Re: message loading with rotating ring
              Vijaya Moderator -Oracle
              Hi Masood,

              As you're seeing the deployment status active of the application, there is no point to turn on the deployment debug flag.

              Regarding 4th point "4. It didn't retarget the ADF libraries. The point is not clear to me."

              It is necessary to re-target the ADF libraries to the managed servers , to which you are deploying your ADF Application. Otherwise you may see the improper behavior of the application due to the dependency on AdF artifacts.

              Also try the below action

              Add the site to trusted sites:

              1) In the browser, select "Tools" -> "Internet Options"
              2) Open the "Security" tab
              3) Select "Trusted sites"
              4) Add the corresponding site, for eg 127.0.0.1

              Please restart the browser and test the application and let us know the results.

              Thanks,
              Vijaya
              • 4. Re: message loading with rotating ring
                Masood
                Hi Vijaya
                All liabraries are retargeted.
                It is already added in trusted site. I checked.
                When I see my deployed application in EM it is up and running. When I click on this deployed application which is under interntal application. It shows me details of this deployed application. Under web Services it is showing message as "no web services found" I doubt here, possibly something is balance to be configured or to be tuned. If you give me your personal email address then I can attach some of the screen shots to you for further clearance.
                Please try to solve this because only this point is balance for my sample application to run successfully.
                Regards,
                Masood
                • 5. Re: message loading with rotating ring
                  Vijaya Moderator -Oracle
                  Is this a Web service or ADF Application?

                  If it is not a web service, you can ignore the message...

                  Thanks,
                  Vijaya
                  • 6. Re: message loading with rotating ring
                    Masood
                    When I open Enterprise Manager I find the below message under
                    Application Deployments
                    Internal Applications
                    ITSDemo (ADFServer) Note: ITSDemo is my test application name and ADFServer is managed server name.

                    It is like this

                    Web Services
                    ------------------------------------------------------------------------------------
                    Service Name port test
                    ------------------------------------------------------------------------------------
                    no web services found



                    I have no idea as what should be here. If it is ignorable then it is ok to me.

                    Rdgs,
                    Masood
                    • 7. Re: message loading with rotating ring
                      Vijaya Moderator -Oracle
                      Masood,

                      Can you please explain what type of application it is?

                      Is it a webservice application or ADF application?

                      Vijaya
                      • 8. Re: message loading with rotating ring
                        Masood
                        It is ADF Application.
                        Rdgs,
                        • 9. Re: message loading with rotating ring
                          Vijaya Moderator -Oracle
                          You may ignore web service error, as it is a ADF application.

                          When you run the ADF application on the browser, do you see any error icon on the status bar of browser?

                          There can be some java script errors also that might stop the application to come up.

                          Try running the application on different browsers and check the behavior.

                          Try the below on Firefox.

                          1. Open the Console

                          Go to the screen where you are experiencing the error. In Firefox, navigate to Tools > Web Developer > Error Console

                          2. Identify the Error

                          The error console will open. If you don't see any errors try reloading the page. The error may be generated when the page loads.

                          Let me know if you find any suspicious errors that might help us to drill down on the root cause of the issue.


                          Thanks,
                          Vijaya
                          • 10. Re: message loading with rotating ring
                            Masood
                            Hi Vijaya
                            Normally I am using Internet Explorer 7. I didn't see any java scripts error on while it is loading. Apart from this I used google chrome and the status is same as ie. I have one 9.7" android tablet. On this tablet also I checked and the result is same. It is showing as loading... with a rotating ring in blue color. Right now I don't have firefox. I need to download it but
                            on these 3 browsers the result is same.
                            Regards,
                            Masood
                            • 11. Re: message loading with rotating ring
                              Masood
                              Hi Vijaya
                              Did you find the root cause for this as I am still waiting it to be solved.
                              Regards,
                              Masood
                              • 12. Re: message loading with rotating ring
                                Vijaya Moderator -Oracle
                                Masood,

                                We may need to gather more details to understand the root cause of the issue.

                                If you are neither seeing any java script errors on the browser nor observing any error in the server console, you can proceed to capture 4-5 set of thread dumps with 5-10 seconds interval and share us the same.

                                This will help us to understand what the application thread was trying to do when loading the page, or the application was in a hung state by making the application threads to get stuck.


                                Please revert back with thread dumps.. Also suggest you to log a Support Ticket with Oracle Support parallely.

                                Thanks,
                                Vijaya
                                • 13. Re: message loading with rotating ring
                                  Masood
                                  Dear Vijaya
                                  as you said, proceed to capture 4-5 set of thread dumps
                                  Please explain how to do it.
                                  Regards,
                                  Masood
                                  • 14. Re: message loading with rotating ring
                                    Vijaya Moderator -Oracle
                                    Masood,

                                    Here are the 2 different ways to take thread dumps in WebLogic Server

                                    1. Use operating system commands to get the thread dumps when WLS starts up from a command-line script:
                                    On Windows OSes, thread dumps can be created by
                                    <ctrl>+<break> -- the thread dumps are generated in the server stdout

                                    2. Using weblogic.WLST:
                                    setDomain.cmd or setDomain.sh depending on the OS
                                    java weblogic.WLST
                                    connect("<username>","<password>","t3://<url>:<port>")
                                    threadDump()


                                    Thanks,
                                    Vijaya