This discussion is archived
0 Replies Latest reply: May 13, 2013 11:28 PM by graham1137 RSS

Patching: HTTP errors when downloading blobs from proxy controller to agent

graham1137 Newbie
Currently Being Moderated
Hi all,

I have a persistent issue which I can't figure out. Oracle support aren't much help.

When applying a Recommended Baseline patchset to our managed Solaris 10 servers, I have observed that blobs are downloaded to the target servers at a rate of 1-2 blobs per minute. I consider this to be quite slow, but that's not my main problem.

At some point during the blob downloads, http errors start appearing in /var/scn/update-agent/logs/error.log on the target server....
HTTP request failed. Reason: Moved temporarily.
HTTP request failed. Reason: Bad gateway.

Eventually, the blob download job fails completely...
118099456 Download aborted.

Our servers are quite a way behind in their patching levels. Consequently, we often need to apply as many as 200 patches to a single server. We are lucky to download 100 patches (blobs) before the http errors begin.

The errors would seem to indicate that the http servers on the proxy controllers are refusing any further connections midway through the blob downloads. I have tried tweaking the httpd.conf file on the proxy controllers - increased the number of httpd processes running and increased MaxClients to 100. None of this has helped.

The proxy controllers have interfaces on the same subnet as the target servers. Network performance between proxy and asset is good.

Has anyone else experienced similar issues with patching ?
Does anyone have any suggestions for httpd.conf settings on the Proxy Controllers ?

Cheers,
Graham

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points