This discussion is archived
6 Replies Latest reply: May 14, 2013 10:56 AM by Nicolas.Gasparotto RSS

Peoplesoft 9.2 PTools 8.53.02 Appliances (April-2013) : issues

Nicolas.Gasparotto Oracle ACE
Currently Being Moderated
Hello,

Not sure if this forum is still monitored by Oracle team, and if it still accurate to post in for the OVA. Anyway, I posted the same on my blog here, but I hope this will help others to put it here.
I had few issues with the latest Peoplesoft Appliances (for VirtualBox):
1. In /etc/selinux/config, SELINUX is not set, it raises a lot of errors, to workaround I set it to "disabled'
2. The report node definition on FSCM92 is not set (I'm surprise since it is set for HCM92), have to do it manually
3. Multiple Samba error like "Unable to connect to CUPS server localhost:631 - Connection refused", I added the line "printing = bsd" in the file /etc/samba/smb.conf to workaround
4. When I started two of the Appliances, the Samba raises other error like "register_name_response: server at IP 192.168.1.20 rejected our name registration of VBOX<20> IP 192.168.1.21 with error code 6.", that's because the "netbios name" is the same across the Appliances, changing it to something unique fix this issue (file /etc/samba/smb.conf).
5. On FSCM92, the application does not start on server boot, to make it right, I did:
{code}[root@fscm92000 ~]# cd /etc/init.d
[root@fscm92000 init.d]# ln -s /opt/oracle/psft/vm/appbatch-start .
[root@fscm92000 init.d]# cd ../rc3.d
[root@fscm92000 rc3.d]# ln -s ../init.d/appbatch-start S98appbatch-start
[root@fscm92000 rc3.d]# cd ../rc5.d
[root@fscm92000 rc5.d]# ln -s ../init.d/appbatch-start S98appbatch-start {code}

Hope that helps others, and hope to have this fixed on the next release.
Feel free to add the issues you may have seen, and workaround if any.

Thanks,

Nicolas.
  • 1. Re: Peoplesoft 9.2 PTools 8.53.02 Appliances (April-2013) : issues
    Nicolas.Gasparotto Oracle ACE
    Currently Being Moderated
    Hello,

    Whilst I was configuring the messaging between HCM92000 and FSCM9200 appliances, I noticed an error in APPSRV.LOG of HCM92000 (not in FSCM92000):
    PSAPPSRV.5457 (1296) [2013-05-08T10:04:49.221 GetCertificate](1) (NET.503): PeopleTools release (8.53) for web server/ Application Designer '' 
    is not the same as Application Server PeopleTools release (8.53.02).  Access denied.
    PSAPPSRV.5457 (1296) [2013-05-08T10:04:49.221 GetCertificate](1) (NET.346): Failed to execute GetCertificate request
    PSAPPSRV.5457 (1303) [2013-05-08T10:04:56.282 GetCertificate](1) (NET.503): PeopleTools release (8.53) for web server/ Application Designer '' 
    is not the same as Application Server PeopleTools release (8.53.02).  Access denied.
    PSAPPSRV.5457 (1303) [2013-05-08T10:04:56.282 GetCertificate](1) (NET.346): Failed to execute GetCertificate request
    PSAPPSRV.5457 (1310) [2013-05-08T10:05:03.646 GetCertificate](1) (NET.503): PeopleTools release (8.53) for web server/ Application Designer '' 
    is not the same as Application Server PeopleTools release (8.53.02).  Access denied.
    PSAPPSRV.5457 (1310) [2013-05-08T10:05:03.646 GetCertificate](1) (NET.346): Failed to execute GetCertificate request
    PSAPPSRV.5457 (1317) [2013-05-08T10:05:09.182 GetCertificate](1) (NET.503): PeopleTools release (8.53) for web server/ Application Designer '' 
    is not the same as Application Server PeopleTools release (8.53.02).  Access denied.
    However, we can connect to the front end application of HCM92000 without any issue or error on the login page. Note that I even did not try to connect to the application within AppDesigner...
    Just this error is coming out time to time, unfortunately not consistently, I'm not able to figure out a scenario to reproduce it.

    Any idea ?

    => addendum : I'm using IE on Windows XP Pro for front end browsing (not supported within PTools 8.53), could it raise the issue ?

    Nicolas.

    Edited by: N Gasparotto on May 10, 2013 12:40 PM
  • 2. Re: Peoplesoft 9.2 PTools 8.53.02 Appliances (April-2013) : issues
    HakanBiroglu Oracle ACE
    Currently Being Moderated
    Hi Nicolas,

    My pre-build (and preconfigured) machine on HCM92 show the following in the PeopleSoft Node Configuration.

    http://i0.wp.com/bloggingaboutoracleapplications.org/wp-content/uploads/169.png

    Shouldn't the Tools Release of the Gateway AppServer be 8.53.02 instead of 8.53?

    PeopleBooks also states
    Tools Release:
    Enter the PeopleTools version number installed on the application server.
    Limit the number you enter to two decimal places. For example, 8.53.
    If you are installing a patch build, include the patch number. For example, if you are installing PeopleTools 8.53 patch build 3, enter the following: 8.53.03
    http://docs.oracle.com/cd/E38689_01/pt853pbr0/eng/pt/tiba/task_SettingOracleJoltConnectionProperties-497d19.html

    Try changing the Tools Release to 8.53.02 to see if it fixes the issue.

    Regards,

    Hakan
  • 3. Re: Peoplesoft 9.2 PTools 8.53.02 Appliances (April-2013) : issues
    Nicolas.Gasparotto Oracle ACE
    Currently Being Moderated
    Hello Hakan,

    Well spotted.

    In the node section, I know that if you mention a version that does not match the tools version of the appserver (till the patch number), the ping won't work (I explained it here). Somehow I did not notice that the version of the default app. server (from Gateway Default App Server Section) was set incorrectly. But since the node is specified, should it raise an error ?
    Hmm, let me do some more tests, I'll report here the results.

    Thanks for the input.

    Nicolas.
  • 4. Re: Peoplesoft 9.2 PTools 8.53.02 Appliances (April-2013) : issues
    Nicolas.Gasparotto Oracle ACE
    Currently Being Moderated
    Hakan, I think you got it right. On the same page of FSCM92000 appliance, the gateway default appserver contains the proper value 8.53.02. I needed a new pair of eyes to check the difference in between.
    Again, I was not able to define a scenario to reproduce it, so let's see if I get that error again for the next couple of days. But I'm pretty confident, that should fix it.

    Cheers,

    Nicola.
  • 5. Re: Peoplesoft 9.2 PTools 8.53.02 Appliances (April-2013) : issues
    485420 Newbie
    Currently Being Moderated
    Hi Nic,

    The issues that you have seen with our Demo appliances are addressed and will be fixed in the next refresh of these appliances.

    Thanks

    -Sheshi
  • 6. Re: Peoplesoft 9.2 PTools 8.53.02 Appliances (April-2013) : issues
    Nicolas.Gasparotto Oracle ACE
    Currently Being Moderated
    Nice to see it will be taken in account, thanks.

    Nicolas.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points