5 Replies Latest reply: May 16, 2013 3:59 AM by user8555906 RSS

    Issue while deploying code from jdeveloper

    948857
      Hi all,

      I am facing the below error while deploying code from jdeveloper:

      01:09:50 PM] Problem in sending HTTP request to the server. Please make sure the server is up and/or check standard HTTP response code for 407
      [01:09:50 PM] Error deploying archive sca_helloworld_rev1.0.jar to partition "default" on server soa_server [http://10.65.218.62:8001]
      [01:09:50 PM] HTTP error code returned [407]
      [01:09:50 PM] No error message is returned from the server.
      [01:09:50 PM] Error deploying archive sca_helloworld_rev1.0.jar to partition "default" on server soa_server [http://10.65.218.62:8001]
      [01:09:50 PM] #### Deployment incomplete. ####
      [01:09:50 PM] Error deploying archive file:/F:/oracle/JdevTmp/mywork/SoaSuiteBook11gChapter2/helloworld/deploy/sca_helloworld_rev1.0.jar
      (oracle.tip.tools.ide.fabric.deploy.common.SOARemoteDeployer)

      Tried to check uncheck proxy services both from jdev, from tools->preferences->web services section but didn't worked out.

      Any help on this deeply appreciated
        • 1. Re: Issue while deploying code from jdeveloper
          BK574
          Try to check your code, You will get this error mostly if something is wrong in your code.
          • 2. Re: Issue while deploying code from jdeveloper
            1002644
            Hi,

            Make sure that server is up and running and you should able to connect from jdeveloper.

            Alternatively make the .sar file or jar file and try to deploy it from emconsole.

            Regards,
            Sri.
            • 3. Re: Issue while deploying code from jdeveloper
              948857
              No error in code...its compiling and build successful.
              • 4. Re: Issue while deploying code from jdeveloper
                BK574
                Try to deploy the sar file directly from EMConsole.

                From EM goto SOA-->SOA-INFRA-->Right click on SOA-INFRA, Select SOA Deployment-->Deploy and give your SAR location.
                • 5. Re: Issue while deploying code from jdeveloper
                  user8555906
                  Hi,
                  I am getting the below error when trying to deploy the simple HelloWorld BPEL into my Dev Server from JDeveloper. and the same project I am able to deploy from the other JDeveloper instance where i have the server installed on the local machine.

                  [01:14:31 PM] ---- Deployment started. ----
                  [01:14:31 PM] Target platform is (Weblogic 10.3).
                  [01:14:31 PM] Running dependency analysis...
                  [01:14:31 PM] Building...
                  [01:14:35 PM] **** One or more compilation errors prevented deployment from continuing.
                  [01:14:35 PM] **** Please correct all compilation errors before deploying.
                  [01:14:35 PM] #### Deployment incomplete. ####
                  [01:14:35 PM] **** One or more compilation errors prevented deployment from continuing. (oracle.adfdt.common.deploy.impl.AdfLibraryBuildDeployer)


                  Here is the SOA log

                  Buildfile: C:\OFMW\jdeveloper\bin\ant-sca-compile.xml

                  scac:
                  [scac] Validating composite "C:\JDeveloper\mywork\OneSource\HelloWorld\composite.xml"
                  [scac] C:\JDeveloper\mywork\OneSource\HelloWorld\composite.xml: error: oracle.fabric.composite.model.CompositeModel.getClientMetadataManager(Z)Loracle/fabric/common/MetadataManager;

                  BUILD FAILED

                  It seems like the issue is with my JDeveloper, please help me in resolving the issue