4 Replies Latest reply: May 16, 2013 12:13 AM by 985084 RSS

    "ERROR disk not found" during boot cdrom installation

    985084
      We were booting a T4-4 server from a Solaris 10 boot ISO and command I used was "boot rcdrom - install as nowin" (i was mounting the ISO using the serial redirection window etc, hence the rcdrom)

      It worked great asking for the" language to be installed" and "network setting and etc."

      then it starts communicating with the jump server to pick up the jumpstart script and etc still working great. but when it start to install, it returned with "ERROR no disk found"

      I am sure there are two 600G disk on the server. not sure why it think there is no disk during the installation. googled it and some said something related to raid and i cannot get a conclusion.

      {0} ok show-disks
      a) /pci@700/pci@1/pci@0/pci@0/LSI,sas@0/disk
      b) /pci@500/pci@1/pci@0/pci@1/pci@0/pci@2/SUNW,qlc@0,1/fp@0,0/disk
      c) /pci@500/pci@1/pci@0/pci@1/pci@0/pci@2/SUNW,qlc@0/fp@0,0/disk
      d) /pci@400/pci@2/pci@0/pci@1/pci@0/pci@2/SUNW,qlc@0,1/fp@0,0/disk
      e) /pci@400/pci@2/pci@0/pci@1/pci@0/pci@2/SUNW,qlc@0/fp@0,0/disk


      {0} ok devalias
      screen /pci@400/pci@1/pci@0/pci@7/pci@0/display@0
      mouse /pci@400/pci@1/pci@0/pci@8/pci@0/usb@0,2/hub@2/device@1/mouse@1
      keyboard /pci@400/pci@1/pci@0/pci@8/pci@0/usb@0,2/hub@2/device@1/keyboard@0
      disk7 /pci@700/pci@1/pci@0/pci@0/@0/disk@p3
      disk6 /pci@700/pci@1/pci@0/pci@0/@0/disk@p2
      disk5 /pci@700/pci@1/pci@0/pci@0/@0/disk@p1
      disk4 /pci@700/pci@1/pci@0/pci@0/@0/disk@p0
      scsi1 /pci@700/pci@1/pci@0/pci@0/@0
      net3 /pci@600/pci@2/pci@0/pci@3/network@0,1
      net2 /pci@600/pci@2/pci@0/pci@3/network@0
      rcdrom /pci@400/pci@1/pci@0/pci@8/pci@0/usb@0,2/hub@2/hub@3/storage@2/disk@0
      rkeyboard /pci@400/pci@1/pci@0/pci@8/pci@0/usb@0,2/hub@2/device@4/keyboard@0
      rscreen /pci@400/pci@1/pci@0/pci@7/pci@0/display@0:r1280x1024x60
      net1 /pci@400/pci@1/pci@0/pci@2/network@0,1
      net0 /pci@400/pci@1/pci@0/pci@2/network@0
      net /pci@400/pci@1/pci@0/pci@2/network@0
      disk3 /pci@400/pci@1/pci@0/pci@0/@0/disk@p3
      disk2 /pci@400/pci@1/pci@0/pci@0/@0/disk@p2
      disk1 /pci@400/pci@1/pci@0/pci@0/@0/disk@p1
      disk0 /pci@400/pci@1/pci@0/pci@0/@0/disk@p0
      disk /pci@400/pci@1/pci@0/pci@0/@0/disk@p0
      scsi0 /pci@400/pci@1/pci@0/pci@0/@0
      scsi /pci@400/pci@1/pci@0/pci@0/@0
      virtual-console /virtual-devices@100/console@1

      name aliases
      {0} ok select scsi0
      {0} ok show-children

      FCode Version 1.00.54, MPT Version 2.00, Firmware Version 5.00.17.00

      Target 9
      Unit 0 Disk HITACHI H106060SDSUN600G A2B0 1172123568 Blocks, 600 GB
      SASDeviceName 5000cca0256f4000 SASAddress 5000cca0256f4001 PhyNum 0
      Target a
      Unit 0 Disk HITACHI H106060SDSUN600G A2B0 1172123568 Blocks, 600 GB
      SASDeviceName 5000cca025671ff4 SASAddress 5000cca025671ff5 PhyNum 1

      f) /pci@400/pci@1/pci@0/pci@8/pci@0/usb@0,2/hub@2/hub@3/storage@2/disk
      g) /pci@400/pci@1/pci@0/pci@0/LSI,sas@0/disk
      h) /iscsi-hba/disk
      q) NO SELECTION

      {0} ok probe-scsi
      This command may hang the system if a Stop-A or halt command
      has been executed. Please type reset-all to reset the system
      before executing this command.
      Do you wish to continue? (y/n) y

      FCode Version 1.00.54, MPT Version 2.00, Firmware Version 5.00.17.00

      Target 9
      Unit 0 Disk HITACHI H106060SDSUN600G A2B0 1172123568 Blocks, 600 GB
      SASDeviceName 5000cca0256f4000 SASAddress 5000cca0256f4001 PhyNum 0
      Target a
      Unit 0 Disk HITACHI H106060SDSUN600G A2B0 1172123568 Blocks, 600 GB
      SASDeviceName 5000cca025671ff4 SASAddress 5000cca025671ff5 PhyNum 1

      {0} ok show-volumes
      No volumes to show
      {0} ok
        • 1. Re: "ERROR disk not found" during boot cdrom installation
          Nik
          Hi.
          Try boot rcdrom -s .
          System will boot from cdrom at single-mode. Then use format for check available disk.
          Label disk to SMI label. ( For this use format -e and use command label ).

          Regards.
          • 2. Re: "ERROR disk not found" during boot cdrom installation
            985084
            nothing seems to come up

            {0} ok boot rcdrom -s

            Boot device: /pci@400/pci@1/pci@0/pci@8/pci@0/usb@0,2/hub@2/hub@3/storage@2/disk@0 File and args: -s
            SunOS Release 5.10 Version Generic_137137-09 64-bit
            Copyright 1983-2008 Sun Microsystems, Inc. All rights reserved.
            Use is subject to license terms.
            WARNING: consconfig: cannot find driver for screen device /pci@400/pci@1/pci@0/pci@7/pci@0/display@0
            Booting to milestone "milestone/single-user:default".
            Configuring devices.
            Using RPC Bootparams for network configuration information.
            Requesting System Maintenance Mode
            SINGLE USER MODE
            # format
            Searching for disks...done
            No disks found!
            • 3. Re: "ERROR disk not found" during boot cdrom installation
              Nik
              Hi.
              According provided information you use DVD with Solaris 10 10/08 (Update 6) .

              Server T4-4 require minimum:
              Oracle Solaris 10 8/11 Update 10 (U10) - pre-installed
              Oracle Solaris 10 09/10 (U9) plus Oracle Solaris 10 08/11 SPARC Patch Bundle *
              Oracle Solaris 10 10/09 (U8) plus Oracle Solaris 10 08/11 SPARC Patch Bundle *

              Donwload and use latest Solaris 10 DVD.

              Regards.
              • 4. Re: "ERROR disk not found" during boot cdrom installation
                985084
                thanks for that. Nik. We have within the company a build process for Solaris and its ISO, apparently the latest ISO for T4-4 was not uploaded. Great help, thanks, an expert indeed!