0 Replies Latest reply: May 16, 2013 11:23 PM by user775296 RSS

    Does adding a template to weblogic domain assign libraries to all managed s

      I tried reading Weblogic documentation everywhere, but didn't find any mention about expected behaviour in such a case.

      Basically I've a domain extension template which has some Weblogic J2EE libraries. I extend an existing Weblogic domain using the following steps. Assume the template contains a single library called 'Lib1'.

      Shut down all servers (including admin server)
      Run a WLST jython script which does the following:

      Start all servers

      After doing this, I go to Weblogic Administration console and check my application via Deployments -> Lib1 -> Targets tab.

      In some environments, I noticed that the new library 'Lib1' is is assigned by default to all available servers. But in other environments, it is assigned to none and I'll have to perform the assignments myself.

      I'm not able to understand the differences in behaviour between different Weblogic environments. I've tried with 10.3.5 and 10.3.6 and it doesn't seem to have any predictability both versions.

      Is there any configuration parameter that determines how assignments are done when a domain is extended by an extension template? Why is the behaviour not consistent?