1 Reply Latest reply on May 17, 2013 1:40 PM by 506787

    OVM Guest wrong hardware clock


      I'm running an Enterprise Linux 6.3 (PVM) on an OVM host.
      The problem is that the date in the EL guest doesn't correspond to the date in the OVM host. The time in /var/log/messages is skewed: it's 6hours too early.
      The hwclock on the host:

      [root@lnx-iaovm01 /]# hwclock
      Fri 17 May 2013 10:53:51 AM CEST -0.737400 seconds

      Output of the command on the guest:

      [root@lnx-ianag01 vm]# hwclock --debug
      hwclock from util-linux-ng 2.17.2
      hwclock: Open of /dev/rtc failed, errno=2: No such file or directory.
      No usable clock interface found.
      Cannot access the Hardware Clock via any known method.

      I tried the following solution: ln -s /dev/rtc0 /dev/rtc
      but I don't have a /dev/rtc0 directory so this isn't very successful

      I also tried setting my TZ in my /etc/profile (so the "date" command atleast is correct but since this is just an environment variable so it doesn't really help either).