2 Replies Latest reply on May 22, 2013 5:45 PM by 996933

    Adding libraries to a cluster


      I want to add libraries to the weblogic server cluster, but not to the domain. Since my domain has different clusters, and each cluster uses different versions of struts applications which other teams needs to deploy.

      So how can I add libraries to the cluster alone? Is it the way we add shared libraries i.e deploying them like any other war/ear file in weblogic?
      But there are many common libraries likes commons-beanutils,commons-lang etc which I added in weblogic_domain lib, without which my deployment shows some errors. So I need to move this jar files to cluster, do I need to add these basic libraries also as shared libraries?? Since other teams use different versions in these jar files also.

        • 1. Re: Adding libraries to a cluster
          Hi Niharika,

          Even though you have different clusters, all clusters are part of the domain only.

          1) One way is create a startupscript for each weblogic server instance and add the libraries to the class path.
          2) Another way is In Administration console in the servers, each of the server will have server classpath. There you can mention.

          Cluster is nothing but logical group of servers the above ways should work.

          You can also use shared library concept. Deploy all the libraries as shared library and map it in weblogic-application.xml file

          Thanks & Regards,
          1 person found this helpful
          • 2. Re: Adding libraries to a cluster
            Thanks a lot for the reply.

            I already tried to deploy it as a shared library and reference it in weblogic.xml since mine is jus war file..But I get the below exception

            An error occurred during activation of changes, please see the log for details.
            Failed to load webapp: 'DCGTools.war'
            Error: Unresolved Webapp Library references for "ServletContext@23514323[app:DCGTools module:DCGTools.war path:/Monitor spec-version:null]", defined in weblogic.xml [Extension-Name: jwg, Specification-Version: 1, exact-match: false]

            My web.xml has the following library embedded :


            Here jwg.jar is deployed in admin console, and it is deployed successfully (I believe)
            The METAINF-MF file in jwg.jar is shown below :

            Manifest-Version: 1.0
            Ant-Version: Apache Ant 1.7.1
            Created-By: 20.1-b02 (Sun Microsystems Inc.)
            Specification-Title: JWG
            Specification-Version: 1.0
            Implementation-Title: JWG Implementation
            Implementation-Version: 1.0
            Extension-Name: jwg
            Built-By: XXXXXXX
            Built-Date: Tue-May-14-2013-05:10:57:PM:Eastern Daylight Time
            Release-Number: N/A
            Build-Cycle: N/A

            Name: common
            Project: emailbuild
            Organization: XXXXXXXXX
            Context: jwg/jwg/jar

            The location of jwg.jar is "C:\ Oracle\ Middleware\ wlserver_10. 3\ common\ deployable-libraries\ jwg. jar".

            Could you help me in figuring out where I am facing an issue ?

            I did the same for jstl, which worked. Do you think the reason I am observing the error is, jwg is manually created and does it need to be registered some where else??

            P.S : I created a server with cluster, to try the second method which you specified. Thanks for it, I didn't know that we can set classpath for server in WL as we do it in Glassfish {How foolish of me ? :( }
            Thanks again,