This discussion is archived
8 Replies Latest reply: May 20, 2013 9:25 AM by 972227 RSS

db_link throwing error

972227 Newbie
Currently Being Moderated
10.2.0.5.0
Enterprise Edition
AIX
NON-RAC
Global_Names=FALSE

Hello Guys, I am trying to connect to the database "test1" from another database using db_links. to create the database link I am using the entire connection description of the tnsentry. When the db_link is created, when I try to query the v$database view, i am getting the error ORA-02019: connection description for remote database not found.

Database TNS_ENTRY
test1 =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = test1)(PORT = 1523))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = test1)
    )
  )
DB_Link
create database link test1 connect to system identified by **** using '(DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = test1)(PORT = 1523))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = test1)'
There is nothing wrong with the TNS entry info. I am able to connect to Toad and SQLPLUS using this TNS-entry.
I also tried replacing the value for HOST from "test1" to the actual hostname of the server, then I wasn't even able to connect to through toad. I was getting No Listener error.
why am i getting the error ORA-02019 when I am trying to connect to the DB test1 through db_link and what can be the possible solution for this error.

Thank You

Edited by: 969224 on May 20, 2013 8:44 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points