5 Replies Latest reply: Jun 6, 2013 4:57 AM by Nat_T Branched to a new discussion. RSS

    Apex Listener 2.0 and Websphere 8.0

    Nat_T
      Hello,

      I am a long time reader and a first time poster in the apex community.
      Currently I am working on a very specific task and I could need some input here.

      I am looking for a way to deploy apex listener to IBM Websphere 8.0 and I am curious if there is anyone out who already got it working.
      I got apex 4.2 on oracle 11g running with either apex listener in standalone mode and ohs + apache modplsql.

      Our environment parameters are

      Oracle 11g
      Apex 4.2
      Apex Listener 2.0
      IBM Websphere 8.0

      Here is how far along I came

      Database (11g):
      - Apex 4.2 installed on Oracle 11g

      Application Server (IBM Websphere 8.0):
      - JDBC provider created
      - J2C alias created
      - Data source created

      Apex Listener:
      - JDK 1.6.0_34 installed
      - Apex Listener configuration via java -jar apex.war


      I have deployed apex.war to Websphere and set the context root to /*


      Next step was creating i.war for apex images.

      I started with java -jar apex.war static <apex directory>\images

      Here I got stuck a bit. My idea was to add another xml file to i.war with Websphere specifics.
      When looking at the created archive i.war I only found the WEB-INF directory with the coresponding xml files,
      but no images. I was expecting the images to be included in i.war.

      Here is what I did

      C:\Oracle\apex_listener_20>java -jar apex.war static C:\Oracle\apex42\apex\images\

      WAR-Generierung abgeschlossen
      WAR-Verzeichnis : C:\Oracle\apex_listener_20\i.war
      Context-Pfad : /i
      Statische Ressourcen : C:\Oracle\apex42\apex\images\


      Does anybody know what's wrong here?

      Another approach would be to copy the image directory to the application server and
      set file serving options accordingly. Since I have no experience with Websphere I yet need to find out how to do that.
      Any hints on how to go along from here are very much appreciated!

      Thanks, Natascha
        • 1. Re: Apex Listener 2.0 and Websphere 8.0
          996889
          admitted on a linux filesystem...

          cd /media/share/Apex/
          /usr/java/jdk1.7.0_02/bin/jar -cvf0 i.war -C apex_4.2.1_en/apex/images/ .

          then I just copied this from the db server to the app server and deployed
          • 2. Re: Apex Listener 2.0 and Websphere 8.0
            1009929
            Hi, do you get the Apex Listener 2.0 and Websphere 8.0 working?? If yes, can you tell me how do yo do that??
            • 3. Re: Apex Listener 2.0 and Websphere 8.0
              1009929
              Hi, do you get the Apex Listener 2.0 and Websphere 8.0 working?? If yes, can you tell me how do yo do that??
              • 4. Re: Apex Listener 2.0 and Websphere 8.0
                Nat_T
                Hello 1006926,

                we are not there yet. After using Apex Listener in standalone mode for a while we will now try again with Websphere.
                • 5. Re: Apex Listener 2.0 and Websphere 8.0
                  Nat_T
                  Thanks kalv,

                  your information helped with deploying i.war.

                  When testing the URL http://192.168.0.55:9080/i/apex_version.txt
                  it shows the expected result: Application Express Version: 4.2.1


                  Now I am back at testing the installation

                  When running http://192.168.0.55:9080/apex/ I get following error message


                  Server error
                  The webpage at http://192.168.0.55:9080/apex/ is currently unavailable. It may be overloaded or down for maintenance.
                  HTTP Error 503 (Service Unavailable): The server is currently unable to handle the request. This code indicates this is a temporary condition, and the server will be up again after a delay.


                  I checked the websphere console, the status of apex.war is started.

                  Can anyone lead me in the right direction where to look for installation errors?

                  Thank you