2 Replies Latest reply: May 30, 2013 12:55 PM by 1010042 RSS

    cant ping gateway even on same segment after restart system

    1010042
      Hello,

      my name is Su, i'm technical engineer.
      I have issue on our system.
      when we restart the OS-solaris11, the system cant ping gateway even on one segment.

      i've tried to reconfigure the IP by ipadm delete-ip and ipadm create-ip, unfortunately it cant resolve the problem.
      routing table looks normal and nic up and can ping itself.

      finally i always execute sysconfig configure command to resolve the problem.

      Please advice why the system cant ping gateway even on one segment after restart

      Edited by: 1007039 on May 21, 2013 12:40 AM

      Edited by: 1007039 on May 21, 2013 12:55 AM
        • 1. Re: cant ping gateway even on same segment after restart system
          Steve H -Oracle
          Hi - Here are some things to check:

          check that the interface link is up on correct physical device

          example:
          # dladm show-phys
          LINK MEDIA STATE SPEED DUPLEX DEVICE
          net0 Ethernet up 1000 full igb0

          confirm IP address and netmask

          # ipadm show-addr
          ADDROBJ TYPE STATE ADDR

          net0/v4 static ok 10.152.230.26/24

          check routing table for correct default router.

          # netstat -rn

          Routing Table: IPv4
          Destination Gateway Flags Ref Use Interface

          default 10.152.230.1 UG 29 162994 net0

          pinging default router should result in arp entry

          # ping 10.152.230.1
          10.152.230.1 is alive

          # arp -an | grep 10.152.230.1

          net0 10.152.230.1 255.255.255.255 00:21:a0:38:fe:00

          running snoop on the interface will confirm network traffic

          # snoop -r -d net0

          10.152.230.26 -> (broadcast) ARP C Who is 10.152.230.1, 10.152.230.1 ?
          10.152.230.1 -> 10.152.230.26 ARP R 10.152.230.1, 10.152.230.1 is 0:21:a0:38:fe:0
          ...
          10.152.230.26 -> 10.152.230.1 ICMP Echo request (ID: 4761 Sequence number: 0)
          10.152.230.1 -> 10.152.230.26 ICMP Echo reply (ID: 4761 Sequence number: 0)

          Edited by: Hodware on May 24, 2013 9:29 AM
          • 2. Re: cant ping gateway even on same segment after restart system
            1010042
            now the gobal has resolved by sysconfig configure command.
            i dont know where the problem is, but my system can access now

            i got new issue on same machine, my cluster heartbeat cant ping the target ip.
            i plug the cross cable to nic port on each domain.

            assume the configuration below :
            domain0 domain3
            nethb0 <--------------------> nethb0
            nethb1 <--------------------> nethb1

            nethb0 192.168.0.10 on domain0 and 192.168.0.20 on domain3
            nethb1 192.168.1.10 on domain0 and 192.168.1.20 on domain3

            but i cant ping the each target ip.

            Here the logs:
            --------------------------------------------------------------------------------------------------------------------
            on domain0:
            nethb0/v4static static ok 192.168.0.10/24
            nethb0 Ethernet up 1000 full nxge7

            on domain3:
            nethb0/v4static static ok 192.168.0.20/24
            nethb0 Ethernet up 1000 full nxge0

            Please advice