2 Replies Latest reply: May 28, 2013 8:28 AM by Edwin van Meerendonk RSS

    Webservice don't work well in APEX...

    user3312945
      Hi everybody! I need to solve a doubt or better I need a light to understand what happen!!!

      I'm using Oracle Application Express 4.2.1.00.08, before upgrade I was using webservice normally.
      But after upgrade the APEX my app that consumed a webservice, stopped work. It's impossible to identify what happened because when the app it is executed appear the following message error:

      ORA-28817: PL/SQL function returned an error.

      I was not convinced about that and I requested an account in the APEX ORACLE (http://apex.oracle.com/) to create the same app. And in the APEX ORACLE the webservice didn't work too, but in the APEX ORACLE appears another error:

      ORA-29273: HTTP request failed ORA-06512: at "SYS.UTL_HTTP", line 1130 ORA-12535: TNS:operation timed out

      I know that the app's webservice really work, because it was verified.

      After that, I solved to access the oracle's website that has a lot of sample of webservice and tried to install one named Amazon S3, and this app didn't work...

      Sorry for the question, but I need a light to understand what I need to do...

      Someone know what happen? It's an Apex upgrade problem? Because I know that these apps worked well...
        • 1. Re: Webservice don't work well in APEX...
          Denes Kubicek
          apex.oracle.com may not be the best place for testing webservices - I am not sure if you can use it there.

          What kind of webservice is it? There is an APE for running webservices manually out of PL/SQL instead of running and testing it from the application. Have you tried that. It would give you a better information on why it fails.

          Denes Kubicek
          -------------------------------------------------------------------
          http://deneskubicek.blogspot.com/
          http://www.apress.com/9781430235125
          https://apex.oracle.com/pls/apex/f?p=31517:1
          http://www.amazon.de/Oracle-APEX-XE-Praxis/dp/3826655494
          -------------------------------------------------------------------
          • 2. Re: Webservice don't work well in APEX...
            Edwin van Meerendonk
            What is your database version?
            When 11, check your ACL