2 Replies Latest reply: May 25, 2013 5:11 PM by gabelh RSS

    Issue facing:Aggregation Server Not Available

    Roshni Shankar
      Hi All,

      I have installed WLS 10.3.4 and OSB 11.1.1.4.0. I created one two node cluster for OSB. Now when I am starting the Admin server and two managed servers , I am getting the following error in MS2(managed server 2) log file.

      ####<14-May-2013 13:30:27 o'clock BST> <Error> <ALSB Statistics Manager> <APORABULVW02PR> <DMZ_OSB_SERVER2> <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <73bea84c38a8684d:1c82c83:13ea25b1f1f:-8000-0000000000000cc3> <1368534627410> *<BEA-473003> <Aggregation Server Not Available. Failed to get remote aggregator
      java.rmi.UnknownHostException: Could not discover URL for server 'OSB_SERVER1'*
      at weblogic.protocol.URLManager.findURL(URLManager.java:145)
      at com.bea.alsb.platform.weblogic.topology.WlsRemoteServerImpl.getInitialContext(WlsRemoteServerImpl.java:94)
      at com.bea.alsb.platform.weblogic.topology.WlsRemoteServerImpl.lookupJNDI(WlsRemoteServerImpl.java:54)
      at com.bea.wli.monitoring.statistics.ALSBStatisticsManager.getRemoteAggregator(ALSBStatisticsManager.java:291)
      at com.bea.wli.monitoring.statistics.ALSBStatisticsManager.access$000(ALSBStatisticsManager.java:38)
      at com.bea.wli.monitoring.statistics.ALSBStatisticsManager$RemoteAggregatorProxy.send(ALSBStatisticsManager.java:55)
      at com.bea.wli.monitoring.statistics.collection.Collector.sendRawSnaphotToAggregator(Collector.java:284)
      at com.bea.wli.monitoring.statistics.collection.Collector.doCheckpoint(Collector.java:243)
      at com.bea.wli.monitoring.statistics.collection.Collector$CheckpointThread.doWork(Collector.java:69)
      at com.bea.wli.monitoring.utils.Schedulable.timerExpired(Schedulable.java:68)
      at com.bea.wli.timer.ClusterTimerImpl$InternalTimerListener.timerExpired(ClusterTimerImpl.java:255)
      at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:273)
      at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
      at weblogic.work.ExecuteThread.execute(ExecuteThread.java:207)
      at weblogic.work.ExecuteThread.run(ExecuteThread.java:176)

      Can anyone please suggest what could be the issue?

      Thanks in advance!