5 Replies Latest reply: May 30, 2013 5:18 AM by KesavanG RSS

    Oracle Management Server is Down in 12C

    KesavanG
      Hi,

      Oracle Management server is not started in 12c,

      While I try to started the OMS services it's shows the below error

      [oracle@prime bin]$ ./emctl start oms
      Oracle Enterprise Manager Cloud Control 12c Release 12.1.0.1.0
      Copyright (c) 1996, 2012 Oracle Corporation. All rights reserved.
      Starting WebTier...
      WebTier Successfully Started
      Starting Oracle Management Server...
      Oracle Management Server is still in the process of getting started
      Timed out waiting for Oracle Management Server to start
      Oracle Management Server is Down
      [oracle@prime bin]$

      Kindly guide me for this issue.

      Regards
      Kesav
        • 1. Re: Oracle Management Server is Down in 12C
          KesavanG
          Hi,

          Here I mentioned the logfile for your reference,

          2013-05-20 18:11:10,716 [Thread-1] INFO wls.OMSController run.1744 - <OUT>
          2013-05-20 18:11:10,716 [Thread-1] INFO wls.OMSController run.1744 - <OUT>sleep for 10 seconds...
          2013-05-20 18:11:20,717 [Thread-1] INFO wls.OMSController run.1744 - <OUT>status of EMGC_OMS1:
          2013-05-20 18:11:20,719 [Thread-1] INFO wls.OMSController run.1744 - <OUT>
          2013-05-20 18:11:20,719 [Thread-1] INFO wls.OMSController run.1744 - <OUT>STARTING
          2013-05-20 18:11:20,719 [Thread-1] INFO wls.OMSController run.1744 - <OUT>
          2013-05-20 18:11:20,720 [Thread-1] INFO wls.OMSController run.1744 - <OUT>sleep for 10 seconds...
          2013-05-20 18:11:30,720 [Thread-1] INFO wls.OMSController run.1744 - <OUT>status of EMGC_OMS1:
          2013-05-20 18:11:30,721 [Thread-1] INFO wls.OMSController run.1744 - <OUT>
          2013-05-20 18:11:30,721 [Thread-1] INFO wls.OMSController run.1744 - <OUT>STARTING
          2013-05-20 18:11:30,721 [Thread-1] INFO wls.OMSController run.1744 - <OUT>
          2013-05-20 18:11:30,722 [Thread-1] INFO wls.OMSController run.1744 - <OUT>sleep for 10 seconds...
          2013-05-20 18:11:40,722 [Thread-1] INFO wls.OMSController run.1744 - <OUT>status of EMGC_OMS1:
          2013-05-20 18:11:40,725 [Thread-1] INFO wls.OMSController run.1744 - <OUT>
          2013-05-20 18:11:40,725 [Thread-1] INFO wls.OMSController run.1744 - <OUT>STARTING
          2013-05-20 18:11:40,725 [Thread-1] INFO wls.OMSController run.1744 - <OUT>
          2013-05-20 18:11:40,729 [Thread-1] INFO wls.OMSController run.1744 - <OUT>timed out waiting for EMGC_OMS1 to be RUNNING
          2013-05-20 18:11:40,729 [Thread-1] INFO wls.OMSController run.1744 - <OUT>status of node manager:
          2013-05-20 18:11:40,729 [Thread-1] INFO wls.OMSController run.1744 - <OUT>Currently connected to Node Manager to monitor the domain GCDomain.
          2013-05-20 18:11:40,732 [Thread-1] INFO wls.OMSController run.1744 - <OUT>1
          2013-05-20 18:11:40,732 [Thread-1] INFO wls.OMSController run.1744 - <OUT>Successfully disconnected from Node Manager.
          2013-05-20 18:11:40,735 [Thread-1] INFO wls.OMSController run.1744 - <OUT>END
          2013-05-20 18:11:40,735 [Thread-2] INFO wls.OMSController run.1744 - <ERR>END
          2013-05-20 18:11:40,762 [main] INFO wls.OMSController processCmd.1392 - wlst process is finished
          2013-05-20 18:11:40,762 [main] INFO wls.OMSController processCmd.1394 - wlst process exited with code 5
          2013-05-20 18:11:40,762 [main] INFO wls.OMSController processCmd.1396 - wlst outstream joined
          2013-05-20 18:11:40,763 [main] INFO wls.OMSController processCmd.1398 - wlst errstream joined
          2013-05-20 18:11:40,763 [main] INFO wls.OMSController processCmd.1406 - process exited with code 5
          2013-05-20 18:11:40,766 [main] DEBUG oms.StatusOMSCmd processStatusOMS.159 - HTTP port in emgc property file: 7203
          2013-05-20 18:11:40,766 [main] DEBUG oms.StatusOMSCmd processStatusOMS.160 - HTTPS port in emgc property file: 7302
          2013-05-20 18:11:40,767 [main] DEBUG oms.StatusOMSCmd processStatusOMS.166 - Webtier HTTP port in emgc property file: 7789
          2013-05-20 18:11:40,767 [main] DEBUG oms.StatusOMSCmd processStatusOMS.167 - Webtier HTTPS port in emgc property file: 7801
          2013-05-20 18:11:40,767 [main] DEBUG oms.StatusOMSCmd processStatusOMS.186 - Using https port.
          2013-05-20 18:11:40,768 [main] DEBUG oms.StatusOMSCmd processStatusOMS.203 - Using webtier https port.
          2013-05-20 18:11:40,954 [main] DEBUG oms.StatusOMSCmd pingOMSCheck.341 - Attempting to connect to https://prime.4iapps.com:7302/em/faces/logon/core-uifwk-console-login
          2013-05-20 18:11:40,970 [main] INFO oms.StatusOMSCmd processStatusOMS.294 - Failed to connect to em login page
          2013-05-20 18:11:40,970 [main] INFO oms.StatusOMSCmd processStatusOMS.295 - Connection refused
          2013-05-20 18:11:40,970 [main] INFO oms.StatusOMSCmd processStatusOMS.296 - Connection exception when trying to hit OMS page. OMS is down
          2013-05-20 18:11:40,970 [main] INFO wls.OMSController statusOMS.1354 - statusOMS finished with result: 8
          2013-05-20 18:11:40,971 [main] INFO wls.OMSController startOMS.940 - startOMS finished with result: 5
          2013-05-20 18:11:40,971 [main] DEBUG oms.StatusOMSCmd processStatusOMS.159 - HTTP port in emgc property file: 7203
          2013-05-20 18:11:40,971 [main] DEBUG oms.StatusOMSCmd processStatusOMS.160 - HTTPS port in emgc property file: 7302
          2013-05-20 18:11:40,972 [main] DEBUG oms.StatusOMSCmd processStatusOMS.166 - Webtier HTTP port in emgc property file: 7789
          2013-05-20 18:11:40,972 [main] DEBUG oms.StatusOMSCmd processStatusOMS.167 - Webtier HTTPS port in emgc property file: 7801
          2013-05-20 18:11:40,972 [main] DEBUG oms.StatusOMSCmd processStatusOMS.186 - Using https port.
          2013-05-20 18:11:40,972 [main] DEBUG oms.StatusOMSCmd processStatusOMS.203 - Using webtier https port.
          2013-05-20 18:11:40,976 [main] DEBUG oms.StatusOMSCmd pingOMSCheck.341 - Attempting to connect to https://prime.4iapps.com:7302/em/faces/logon/core-uifwk-console-login
          2013-05-20 18:11:40,977 [main] INFO oms.StatusOMSCmd processStatusOMS.294 - Failed to connect to em login page
          2013-05-20 18:11:40,977 [main] INFO oms.StatusOMSCmd processStatusOMS.295 - Connection refused
          2013-05-20 18:11:40,977 [main] INFO oms.StatusOMSCmd processStatusOMS.296 - Connection exception when trying to hit OMS page. OMS is down
          2013-05-20 18:11:41,004 [main] INFO wls.OMSController statusOMS.1354 - statusOMS finished with result: 8

          Awaiting for your reply

          Regards
          Kesav
          • 2. Re: Oracle Management Server is Down in 12C
            Venkata Thiruveedhi-Oracle
            Hi Kesav,

            Not a known case.

            Once try to cleanly kill all the process and bring the OMS up and verify the status:

            1.Stop the OMS
            <OMS_HOME>/bin>./emctl stop oms -all

            2.Check if Admin server or Managed Server processes are still running and kill them if any found:
            $ps -ef | grep EMGC_ADMIN
            $ps -ef | grep EMGC_OMS1

            3.Start the OMS
            <OMS_HOME>/bin>./emctl start oms

            Best Regards,
            Venkat
            • 3. Re: Oracle Management Server is Down in 12C
              SAML.
              Hi,

              I found this problem a few times and I always fix it by restart it cleanly, i.e. by shutdown "emctl stop oms -all" and kill any process still leftover and restart OEM again

              SAM L.
              • 4. Re: Oracle Management Server is Down in 12C
                MarkM-Oracle
                Kesav,

                I notice that you are on version 12.1.0.1. First you should upgrade the latest version (12.1.0.2) and apply all recommended patches. If this problem persists after upgrading I would recommend logging an SR with Oracle Support so that they can diagnose the root cause.

                Regards, Mark.
                • 5. Re: Oracle Management Server is Down in 12C
                  KesavanG
                  Hi,

                  Now the OMS service is up & running

                  Simply i restart the services once again

                  Thanks for your valuable suggestions.

                  Regards
                  Kesav