7 Replies Latest reply on Jun 1, 2013 7:18 PM by Dude!

    ASMlib needed ?

    1006937
      Hi,

      I have OEL 5.8 (kernel 2.6.32-300)
      I want to install ASM

      What I need ? I am confused abour ASMLib

      I can't find asm rpm for my kernel on OTN (only for kernel 2.6.18)

      Can you help me ?

      Thanks in advance

      Regards
        • 1. Re: ASMlib needed ?
          Dude!
          That's because you are using the Oracle UEK kernel, which already includes the ASMLIB kernel module.

          <pre>
          # modprobe -v oracleasm
          insmod /lib/modules/2.6.32-300.10.1.el5uek/kernel/drivers/block/oracleasm/oracleasm.ko
          </pre>

          The only thing you need to install are:

          <pre>
          # yum install oracleasm-support

          # wget http://download.oracle.com/otn_software/asmlib/oracleasmlib-2.0.4-1.el5.i386.rpm
          # yum install oracleasmlib-2.0.4-1.el5.i386.rpm
          or
          # wget http://download.oracle.com/otn_software/asmlib/oracleasmlib-2.0.4-1.el5.x86_64.rpm
          # yum install oracleasmlib-2.0.4-1.el5.x86_64.rpm
          </pre>

          The oracleasmlib package is not GPL and hence not part of public YUM, but provides the oracleasm-discover utility (and others) for the Oracle 11g ASM installer to automatically discover disks in /dev/oracleasm (ORCL:*).
          1 person found this helpful
          • 2. Re: ASMlib needed ?
            1006937
            Hi,

            Thanks Dude

            modprobe -v oracleasm give nothing
            but lsmod oracleasm is ok

            what I understand:
            oracleasm = kernel driver => OK
            oracle-support => from ISO
            oracleasmlib : not GPL => not on ISO => download from oracle site

            I need these 3 files installed ?

            Thanks for your help
            • 3. Re: ASMlib needed ?
              Dude!
              yes.
              • 4. Re: ASMlib needed ?
                Flávio Soares
                Hi

                You can download asmlib from this page:

                http://www.oracle.com/technetwork/server-storage/linux/downloads/rhel5-084877.html

                Please let me know, what yours kernel devel? (uname -r)

                For sample my linux is x86_64:

                Then I need download these rpm files, because my architecture is Intel EM64T (x86_64) (http://www.oracle.com/technetwork/server-storage/linux/downloads/rhel5-084877.html#oracleasm_rhel5_amd64):

                - oracleasm-support-2.1.7-1.el4.x86_64.rpm
                - oracleasmlib-2.0.4-1.el4.x86_64.rpm


                So ... I need also download the rpm file, because my kernel devel is (2.6.9-78.ELlargesmp)

                [root@skathi-n1 ~]# uname -r
                2.6.9-78.ELlargesmp

                - oracleasm-2.6.9-78.ELlargesmp-2.0.5-1.el4.x86_64.rpm
                1 person found this helpful
                • 5. Re: ASMlib needed ?
                  Dude!
                  The OP is using Oracle Linux 5.8 with UEK kernel (2.6.32). There is no need to install any oracleasm kernel module, nor will it be appropriate to install any software for EL4.
                  • 6. Re: ASMlib needed ?
                    1006937
                    Hi Dude,

                    I need oracleasm kernel module: yes or no ?

                    Thanks for your help
                    • 7. Re: ASMlib needed ?
                      Dude!
                      I have OEL 5.8 (kernel 2.6.32-300)
                      You do not need to install the ASMLib kernel module because it is included with the UEK kernel.

                      Version 2.6.32 is the Oracle UEK kernel.
                      1 person found this helpful