5 Replies Latest reply on May 28, 2013 3:28 PM by Rmsarma-Oracle

    EDQ 9.0.7 - "Password reset"

      This is the synopsis of the issue -

      OS - Windows 2008 Server
      EDQ - 9.0 media pack using V37924-01 zip downloaded from e-delivery today

      After the install went through successfully I invoked the Launchpad, to re-set the password using dnadmin/dnadmin[ as per documentation]. It said "Password Expired" in Red, but did not prompt the usual old password, new password dialog. When I now enter a new password for example [ "director1", which works on a Windows 2007 64 Bit laptop] , I get the following :
      **Wrong username/password entered**

      From here on, it seems to be a point of no return [ regardless of which password I enter].

      Any thoughts ?

      Edited by: rmsarma on May 22, 2013 12:07 PM

      I have one update.

      When I used my Windows 2007 machine as the client to invoke the Launchpad in the EDQ Server which is on Windows 2008, the password reset works and I have been able to launch dnDirector. This should complete the Post Install step for now.

      However I would have expected that performing the client activity on the Server, should have worked. We need the answer for the following questions :

      1. Does the Server on which EDQ installed [ if in case, we want to perform any client activity from the server itself] require a separate Java 1.6 install, in spite of the fact that
      the OEDQ install already comes with a Java Run time ?

      2. Does the password re-set [ for the first time] need to be performed only with the Launchpad OR we could use the dashboard ? As per documentation, any client should be fine.

      Edited by: rmsarma on May 22, 2013 12:07 PM

      Edited by: rmsarma on May 22, 2013 12:37 PM
        • 1. Re: EDQ 9.0.7 - "Password reset"

          I believe this must have been a blip of some kind (perhaps the spawned window that prompted you for a password change was usurped by another window from another app or similar). The password expiry functionality is fairly simple and well tested. It does not vary between platforms.

          In answer to 1, if you installed EDQ using the Windows installer, you will have installed Tomcat, Java, and Postgres. There is no need for anything further on the server, though if you want to update the JDK and point Tomcat at it you can. However, all clients that access the EDQ server do need to have a JRE installed (Java 1.6 or later), so that they can launch the client applications with Java Webstart.

          In answer to 2, any client works, and the experience is the same. For installation purposes it is probably easiest just to log into the Server Configuration or User Configuration web pages to bring up the prompt to enter a new password.


          • 2. Re: EDQ 9.0.7 - "Password reset"
            Mike appreciate your feedback
            • 3. Re: EDQ 9.0.7 - "Password reset"
              Mike -

              For the question #1 - install JDK on the Server Machine [ on top of the JRE which is installed OTTB by OEDQ ], the issue gets resolved [ i.e., I am able to perform client activities on the Server]. should this be stated in the install guide as a requirement seems like support was not convinced that JDK was required but optional.
              • 4. Re: EDQ 9.0.7 - "Password reset"
                To be clear on what happened here:

                - You installed EDQ as a server on a Windows machine. This installs the JRE and other required components is a complete server install, intended largely for test and development use. Clients also with the JRE would be able to connect to the server and use the client apps.

                - On the server machine, Windows did not recognize the installed JRE (as installed using the EDQ Windows Installer) under Control Panel -> Java. I think if a standalone JRE installer is not used, Windows does not necessarily link to the JRE correctly. This meant that you could not launch the Webstart apps on the server machine itself.

                So, installing a separate JDK solved the problem because Windows then recognized the installed version of Java and enabled Java Webstart. You could have achieved the same effect by pointing Java at the right JRE in the control panel. The server installation was already complete.

                Hope this makes sense.