This discussion is archived
5 Replies Latest reply: Aug 15, 2013 10:37 AM by tx103108 RSS

Oracle Application Express does not start on boot - only on manual start

1012248 Newbie
Currently Being Moderated
[Environment see at the bottom]

Oracle Application Express does not start on boot - only on manual start. After installation (following [1] and [2]) "Oracle Application Express" starts fine and I can see the following in netstat:
tcp6 :::8080 :::* LISTEN 645/tnslsnr

chkconfig oracle-xe
oracle-xe 2345

After every reboot, "Oracle Application Express" does /not/ listen on port 8080:

service oracle-xe status shows:
Alias LISTENER
Version TNSLSNR for Linux: Version 11.2.0.2.0 - Production
Start Date 01-JUN-2013 12:22:19
Uptime 0 days 0 hr. 0 min. 56 sec
Trace Level off
Security ON: Local OS Authentication
SNMP OFF
Default Service XE
Listener Parameter File /u01/app/oracle/product/11.2.0/xe/network/admin/listener.ora
Listener Log File /u01/app/oracle/diag/tnslsnr/ubuntu1204/listener/alert/log.xml
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC_FOR_XE)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=ubuntu1204)(PORT=1521)))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...

After "service oracle-xe restart":

Listening Endpoints Summary...
[same as above] (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=ubuntu1204)(PORT=8080))(Presentation=HTTP)(Session=RAW))
Services Summary...
[same as above]
Service "XE" has 1 instance(s).
Instance "XE", status READY, has 1 handler(s) for this service...
Service "XEXDB" has 1 instance(s).
Instance "XE", status READY, has 1 handler(s) for this service...

Last entry in log.xml:
<msg time='2013-06-01T08:46:15.933+02:00' org_id='oracle' comp_id='tnslsnr'
type='UNKNOWN' level='16' host_id='ubuntu1204'
host_addr='127.0.1.1'>
<txt>01-JUN-2013 08:46:15 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=ubuntu1204)(USER=oracle))(COMMAND=status)(ARGUMENTS=64)(SERVICE=LISTENER)(VERSION=186647040)) * status * 0
</txt>
</msg>

Environment:
Oracle Database XE 11g Release 2
OS: Ubuntu 12.04 LTS 64-bit (fully patched, VMWare tools not installed)
Virtualization: VMware Workstation 9.0.2 on Windows 8 64-bit

[1] http://meandmyubuntulinux.blogspot.de/2012/05/installing-oracle-11g-r2-express.html
[2] http://meandmyubuntulinux.blogspot.de/2012/06/trouble-shooting-oracle-11g.html

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points