This discussion is archived
1 2 Previous Next 21 Replies Latest reply: Jun 22, 2013 1:11 PM by AmitShil Go to original post RSS
  • 15. Re: NIC Bonding not behaving as it should
    AmitShil Newbie
    Currently Being Moderated
    Marked answered inadverntly
  • 16. Re: NIC Bonding not behaving as it should
    AmitShil Newbie
    Currently Being Moderated
    Didn't wanted to hijack chen's thread so posting on this one.

    Did a brand new setup with OL6, virbr0 is now gone (so that's my mistake selecting something stupid in all my VMs :P), however even after doing bonding setup from scratch its not working for me on this new VM, exactly the behaviour last experienced.

    Not sure but i think i'll conclude that it doesn't work on VMs :( unless somebody can comment on any of my open threads on various forums.

    I am posting the configuration on this VM, if somebody can identify any isuses here?

    n/w o/p

    [root@localhost ~]# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth2: <NO-CARRIER,BROADCAST,MULTICAST,SLAVE,UP> mtu 1500 qdisc pfifo_fast master bond0 state DOWN qlen 1000
    link/ether 08:00:27:1e:89:ef brd ff:ff:ff:ff:ff:ff
    3: eth1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master bond0 state UP qlen 1000
    link/ether 08:00:27:1e:89:ef brd ff:ff:ff:ff:ff:ff
    4: sit0: <NOARP> mtu 1480 qdisc noop state DOWN
    link/sit 0.0.0.0 brd 0.0.0.0
    5: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
    link/ether 08:00:27:1e:89:ef brd ff:ff:ff:ff:ff:ff
    inet 192.169.25.6/29 brd 192.169.25.7 scope global bond0
    inet6 fe80::a00:27ff:fe1e:89ef/64 scope link
    valid_lft forever preferred_lft forever

    Bonding driver

    [root@localhost ~]# lsmod | grep -i bond
    bonding 102210 0
    ipv6 264702 28 bonding,sit,ip6t_REJECT,nf_conntrack_ipv6


    bond0 in proc

    [root@localhost ~]# cat /proc/net/bonding/bond0
    Ethernet Channel Bonding Driver: v3.5.0 (November 4, 2008)

    Bonding Mode: fault-tolerance (active-backup)
    Primary Slave: None
    Currently Active Slave: eth1
    MII Status: up
    MII Polling Interval (ms): 1000
    Up Delay (ms): 0
    Down Delay (ms): 0

    Slave Interface: eth1
    MII Status: up
    Link Failure Count: 0
    Permanent HW addr: 08:00:27:1e:89:ef

    Slave Interface: eth2
    MII Status: down
    Link Failure Count: 0
    Permanent HW addr: 08:00:27:f3:04:ed

    can't see any issues in teh log

    May 11 23:11:54 localhost kernel: ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
    May 11 23:11:54 localhost kernel: bonding: bond0: Adding slave eth2.
    May 11 23:11:54 localhost kernel: e1000: eth2 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
    May 11 23:11:54 localhost kernel: bonding: bond0: enslaving eth2 as a backup interface with an up link.
    May 11 23:14:28 localhost kernel: e1000: eth1 NIC Link is Down
    May 11 23:14:28 localhost kernel: bonding: bond0: link status definitely down for interface eth1, disabling it
    May 11 23:14:28 localhost kernel: bonding: bond0: making interface eth2 the new active one.
    May 11 23:17:06 localhost kernel: e1000: eth2 NIC Link is Down
    May 11 23:17:06 localhost kernel: bonding: bond0: link status definitely down for interface eth2, disabling it
    May 11 23:17:06 localhost kernel: bonding: bond0: now running without any active interface !
    May 11 23:17:11 localhost kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
    May 11 23:17:11 localhost kernel: bonding: bond0: link status definitely up for interface eth1.
    May 11 23:17:11 localhost kernel: bonding: bond0: making interface eth1 the new active one.
    May 11 23:17:11 localhost kernel: bonding: bond0: first active interface up!
    May 11 23:26:27 localhost kernel: bonding: bond0: Removing slave eth1
    May 11 23:26:27 localhost kernel: bonding: bond0: Warning: the permanent HWaddr of eth1 - 08:00:27:1e:89:ef - is still in use by bond0. Set the HWaddr of eth1 to a different address to avoid conflicts.
    May 11 23:26:27 localhost kernel: bonding: bond0: releasing active interface eth1
    May 11 23:26:27 localhost kernel: bonding: bond0: Removing slave eth2
    May 11 23:26:27 localhost kernel: bonding: bond0: releasing backup interface eth2
    May 11 23:26:27 localhost kernel: lo: Disabled Privacy Extensions
    May 11 23:26:27 localhost kernel: bonding: bond0: setting mode to active-backup (1).
    May 11 23:26:27 localhost kernel: bonding: bond0: Setting MII monitoring interval to 1000.
    May 11 23:26:27 localhost kernel: ADDRCONF(NETDEV_UP): bond0: link is not ready
    May 11 23:26:27 localhost kernel: bonding: bond0: Adding slave eth1.
    May 11 23:26:27 localhost kernel: bonding: bond0: enslaving eth1 as a backup interface with a down link.
    May 11 23:26:27 localhost kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
    May 11 23:26:27 localhost kernel: bonding: bond0: Adding slave eth2.
    May 11 23:26:27 localhost kernel: bonding: bond0: enslaving eth2 as a backup interface with a down link.
    May 11 23:26:28 localhost kernel: bonding: bond0: link status definitely up for interface eth1.
    May 11 23:26:28 localhost kernel: bonding: bond0: making interface eth1 the new active one.
    May 11 23:26:28 localhost kernel: bonding: bond0: first active interface up!
    May 11 23:26:28 localhost kernel: ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
    May 11 23:27:48 localhost kernel: e1000: eth1 NIC Link is Down
    May 11 23:27:48 localhost kernel: bonding: bond0: link status definitely down for interface eth1, disabling it
    May 11 23:27:48 localhost kernel: bonding: bond0: now running without any active interface !
    May 11 23:28:09 localhost kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
    May 11 23:28:09 localhost kernel: bonding: bond0: link status definitely up for interface eth1.
    May 11 23:28:09 localhost kernel: bonding: bond0: making interface eth1 the new active one.
    May 11 23:28:09 localhost kernel: bonding: bond0: first active interface up!



    ifcfg configuration

    [root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth*
    DEVICE="eth1"
    ONBOOT="yes"
    TYPE=Ethernet
    BOOTPROTO=none
    MASTER=bond0
    SLAVE=yes
    DEVICE="eth2"
    ONBOOT="yes"
    TYPE=Ethernet
    BOOTPROTO=none
    MASTER=bond0
    SLAVE=yes



    Regards Amit
  • 17. Re: NIC Bonding not behaving as it should
    user203465 Newbie
    Currently Being Moderated
    Hi,

    i tried to reproduce that problem on:

    a) win/ vmware workstation 9.02 within a vm running OEL6.3
    b) win/ vmware workstation 9.02 within a vm running debian "wheezy"

    and

    c) a physical system running OEL6.3.

    on oracle linux, i tried "rhel compatible" and "unbrakable"-kernel.

    all systems showed exactly the same behaviour while using "active-backup"-mode for bond0.

    bond-driver logged, that (for testing) eth0 went down and eth1 will be used instead as bond-master. so far, so good. but it seems as if ip-stack didn't work anymore, even if eth0 is being plugged in again (and in this case again, it oi logged that eth0 is back and running).

    are there any further steps to be considered while using active-backup mode on one single switch? MAC-Address handling should be transparent by default, so the switch does not need to know anything about it?

    any ideas?

    tia

    regards
    /n1k1
  • 19. Re: NIC Bonding not behaving as it should
    WadhahDAOUEHI Journeyer
    Currently Being Moderated
    Hi,
    I have installed an OEL5u9 on VirtuallBox 4.2, and i found this problem when i tested the bonding, and i found a solution when i added the option fail_over_mac=1 (this option is a good option just for the mode 1)

    so you can test it:

    # service network stop

    # modprobe -r bonding

    # modprobe bonding mode=1 miimon=100 fail_over_mac=1

    # service network start

    I hope that help you :)
    Best Regards
  • 20. Re: NIC Bonding not behaving as it should
    Dude! Guru
    Currently Being Moderated
    ... which was already mentioned and explained ;-)
  • 21. Re: NIC Bonding not behaving as it should
    AmitShil Newbie
    Currently Being Moderated

    Perfect, that's real good job mate doing that write up .. have just tried the setup and has worked wonders!! .. can't thank you enough.. Cheers!

     

    Amit

1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points