This discussion is archived
4 Replies Latest reply: Jun 4, 2013 3:20 AM by divya RSS

Email process doesn't work

983316 Newbie
Currently Being Moderated
Hello,

I have procedure in my application that must send emails, but it is not working. So I tried to send a normal email from application using this block

"DECLARE
l_body CLOB;
BEGIN
l_body := 'Thank you for your interest in the APEX_MAIL
package.'||utl_tcp.crlf||utl_tcp.crlf;
l_body := l_body ||' Sincerely,'||utl_tcp.crlf;
l_body := l_body ||' The APEX Dev Team'||utl_tcp.crlf;
apex_mail.send(
p_to => 'my_email', -- change to your email address
p_from => 'Another_email', -- change to a real senders email address
p_body => l_body,
p_subj => 'APEX_MAIL Package - Plain Text message');
END;"

But this is also not working, am I missing something? Knowing that I am working in a local network.

Thanks!
  • 1. Re: Email process doesn't work
    apexsan Newbie
    Currently Being Moderated
    In your Apex database schema, check to see if there are any indications in the tables www_flow_mail_log, www_flow_mail_queue
  • 2. Re: Email process doesn't work
    TexasApexDeveloper Guru
    Currently Being Moderated
    Is this the way that you have it setup??
    DECLARE
    l_body CLOB;
    BEGIN
    l_body := 'Thank you for your interest in the APEX_MAIL
    package.'||utl_tcp.crlf||utl_tcp.crlf;
    l_body := l_body ||' Sincerely,'||utl_tcp.crlf;
    l_body := l_body ||' The APEX Dev Team'||utl_tcp.crlf;
    apex_mail.send(
    p_to => 'my_email', -- change to your email address
    
    Is this e-mail address correct??
    
    p_from => 'Another_email', -- change to a real senders email address
    
    Same question here?
    
    p_body => l_body,
    p_subj => 'APEX_MAIL Package - Plain Text message');
    END;
    Simple question, do you have APEX configured with an E-Mail server??

    Thank you,

    Tony Miller
    Ruckersville, VA
  • 3. Re: Email process doesn't work
    divya Newbie
    Currently Being Moderated
    Hi Najla,

    You can check with your DBA if you have privileges to the UTL_SMTP package and APEX_MAIL.
    Configure your mail settings in the Internal Workspace > Instance settings



    -Divya
  • 4. Re: Email process doesn't work
    divya Newbie
    Currently Being Moderated
    You can use the inbuilt 'Send e-mail' process .

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points