1 Reply Latest reply on Jun 4, 2013 5:40 AM by davidp 2

    About Apex Connection.

      You don't have permission to access /dev/apex/apex on this server. --- Is the error showing when i am trying to connect through this link

      Issue started in this way :

      I needed to create a workspace so i tried to log in into ADMIN but unfortunately given wrong password 3 times which made it lock and when we try to reset password for ADMIN by running *@apexcnpwd.sql* it thrown error as Password validation Failed though we followed rules of the password as 1 caps, 1 alphanumeric,etc . I tried Goodday123$ and Niceday123$ and many more but it didnt accept and i just guessed as its not accepting because of version as we are using APEX 4.2 and may be file is of older version but i didnt try anything in this guess .. After that i just checked user status in DBA_USERS and APEX_040200 and APEX_PUBLIC_USER and FLOW_FILES were in expired status .*APEX_040200 and APEX_PUBLIC_USER* were in locked status also for which also we dont know password so i changed password to unlock it and make it in OPEN status .. But unfortunately after doing this URL mentioned at top stopped working .. I felt as i made a mistake by changing password of APEX_PUBLIC_USER and by not updating same in dads.conf file .. So we configured dads.conf file also but still URL was not working .. And just simply guessed and restarted apache server and its suddenly started working .. But still unable to change password of ADMIN as same error password validation failed .. Finally in this scenario we just opened file apexchpwd.sql to see as what's issue and unfortunately issue was in file as schema set in the file was APEX_040100 which we changed to APEX_040200 and finally got changed successfully and restarted Oracle HTTP server..

      Not my doubt in this scenario is what's my mistake exactly I referred lot of documents but i just have a doubt whether because i changed password of APEX_PUBLIC_USER and APEX_040200 users so URL stopped working or because of ADMIN got locked so issue came .. Or else its before changing password applications were working fine and just ADMIN password alone was an issue but as i changed URL itself didnt get open and whole DEV team was idle for hours or else as we restarted apache server so immediately URL worked so Is it problem was in Apache server . . Pls suggest as what was my exact mistake and more on this case .. However problem is solved but i want to understand it in deep way so that again same should not happen ..