3 Replies Latest reply: Jun 4, 2013 8:09 AM by Victor Armbrust RSS

    Exadata network freeze

    1005177
      I have a layer 2 problem (network looping) in my network some days ago and this problem was solved when I removed all exadata data connection from my external network switches. Somebody have similar problem here ?
        • 1. Re: Exadata network freeze
          994218
          Exadata has its own setup of switches and other networking stuff. So, you really need not to add exadata machines in to your network other than Database Machines, which are accessible to out side of exadata env.

          You need to set up Exadata DB machine IP's and cell server IP just once at time of setup and after that, Cell servers doesn't have any communication out of exadata network. If you are saying you remote DB machines from you network and problem was solved. This is really strange.

          Thanks,
          http://www.dbas-oracle.com/
          • 2. Re: Exadata network freeze
            Marc Fielding
            This sounds like a misconfigured active-active bonding configuration. With an active-active bond, both the switch and the database server must have link aggregation properly configured on the right ports, unlike active-passive bonding where no switch configuration is required.

            You can test this by disabling bonding in your network configuration, and seeing if your network loop goes away.

            There's some brief network channel bonding documentation in chapter 2 of the Exadata Owner's Guide. The official (if somewhat technical) documentation would be in the Linux kernel's bonding.txt though: https://www.kernel.org/doc/Documentation/networking/bonding.txt

            Marc
            • 3. Re: Exadata network freeze
              Victor Armbrust
              Yes. I Had this problem at Oracle ACS on a customer which I used to attend to. In that case the problem was related to a problem at Customer Network Switch (outside Exadata). The switch was missconfigured a VLAN, so the Exadata was freezing all other ports. I also update from 11.2.3.1.0 to 11.2.3.2.1.

              It is very unsual problem, my recommendation is to double check all your network configurations (outside exadata). The CISCO Switch inside Exadata is a "all-to-all" port, without any filters or particulars VLANs

              Victor