8 Replies Latest reply on Jun 6, 2013 8:05 AM by samiullah.khaan

    wget error


      I am getting following error:

      [root~]# wget http://public-yum.oracle.com/public-yum-ol6.repo
      --2013-06-03 08:49:44-- http://public-yum.oracle.com/public-yum-ol6.repo
      Resolving public-yum.oracle.com... failed: Temporary failure in name resolution.
      wget: unable to resolve host address “public-yum.oracle.com”

      I tried all that is posted on internet but in vain.

      While installing Oracle Linux 6, I skipped the network configuration step. Not sure if this is the error.

      Internet is not working on this OEL 6 on vmware on windows7. However, Internet is working fine using the same wireless connection on Windows 7.

      Please help me fix this ASAP.

      Regards n thanks!
        • 1. Re: wget error
          Oracle Linux 6 like most OS systems use DHCP by default. However, if you did not configure the network during the installation or did not selected "Connect automatically", then chances are your network adapter in Oracle Linux is down.

          You can try the following command as root:
          ifconfig eth0 up
          service network restart
          To automatically start your network adapter after a system restart, add
          to /etc/sysconfig/network-scripts/ifcfg-eth0

          If this does not solve your problem you might be using a wrong adapter type in your virtual machine setup. The adapter that will allow the guest OS to connect to the Internet under most circumstances is the NAT based adapter.

          I suggest to check the output of the "ifconfig" command to see if your network adapter (eth0) was detected and has a valid IP address assigned. Also see /etc/resolv.conf to check your DNS nameserver configuration.
          • 2. Re: wget error
            Hi Dude:

            Thanks for the initial insight into the problem but it is still there. I followed your guidelines and then ran wget still the same error:

            [root@ yum.repos.d]# ifconfig eth0 up
            [root@ yum.repos.d]# service network restart
            Shutting down interface eth0: [  OK  ]
            Shutting down loopback interface: [  OK  ]
            Bringing up loopback interface: [  OK  ]
            [root@ yum.repos.d]# vi /etc/sysconfig/network-scripts/ifcfg-eth0
            [root@ yum.repos.d]# ifconfig
            lo Link encap:Local Loopback
            inet addr: Mask:
            inet6 addr: ::1/128 Scope:Host
            UP LOOPBACK RUNNING MTU:16436 Metric:1
            RX packets:8 errors:0 dropped:0 overruns:0 frame:0
            TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:0
            RX bytes:480 (480.0 b) TX bytes:480 (480.0 b)

            [root@ yum.repos.d]#
            [root@ yum.repos.d]# wget http://public-yum.oracle.com/public-yum-ol6.repo
            --2013-06-04 05:23:24-- http://public-yum.oracle.com/public-yum-ol6.repo
            Resolving public-yum.oracle.com... failed: Temporary failure in name resolution.
            wget: unable to resolve host address “public-yum.oracle.com”
            [root@ yum.repos.d]#

            From the ifconfig output above its clear that eth0 is not detected. Well, I am on a wireless network and it set to be detected automatically. Its quite strange that I was able to access the yum repository in RHEL6.4 but in OEL6 its not working. I had not done anything specific for RHEL64.

            This is my /etc/resolv.conf entry

            # Generated by NetworkManager
            search com

            # No nameservers found; try putting DNS servers into your
            # ifcfg files in /etc/sysconfig/network-scripts like so:
            # DNS1=xxx.xxx.xxx.xxx
            # DNS2=xxx.xxx.xxx.xxx
            # DOMAIN=lab.foo.com bar.foo.com

            If I have to specify a DNS which IP should I use? the one from LAN Adapter Wireless Network IP (output of ipconfig in MSDOS on Windows 7 on which VMware in which OEL6 is installed) or VMNet1/VMNet8 IP?

            Please advise.

            Thanks n regards,
            • 3. Re: wget error
              Hi Dude:

              Many thanks! I am bale to access the yum repository for oracle 11gr2 preinstall.

              I ran the installer but some pre-requisites (library files such as gcc, unixODBC etc) checks failed. I ignored them and proceed with the installation. Its going on....lets see wat happens. fingers xed.

              Please help me with if I need to make the prequisite cheks passed.

              Regards, Samiullah
              • 4. Re: wget error
                You should not need to install additional software in your OL guest system, or even be able to access the Wifi device of your host system directly. The virtualization software should provide an Ethernet device and handle the necessary communication and routing with the active network on your host system, whatever it is.

                I have not used VMware for a while and switched to Oracle VM VirtualBox. It has no trouble with OL 6.4 to detect the Ethernet device. The way things work under VMware are very similar. I suggest you check your virtual machine settings to make sure you have an appropriate network adapter enabled. If it is, perhaps you are using a very old version of VMware and the Oracle UEK2 kernel, which is a major release version upgrade from the RHCK kernel, is no longer compatible with your VMware software.
                • 5. Re: wget error
                  Hi Dude:

                  Thanks a lot for your guidance! My DB was up and running including the EM yesterday. But when I tried to start the EM first through browser it failed then through $emctl start dbconsole it again failed. The second time it reported missing of some oc4jDBCONSOLE_localhost_SID misiing. Someone suggested to rename the existing oc4j_XXX directory to this directory but it still didnt work. However, I am able to login to sqlplus through command line.

                  my $HOSTNAME value is different from $ORACLE_HOSTNAME. Is it becaue of this?

                  Please help urgently.

                  • 6. Re: wget error
                    The Oracle installer scans /etc/hosts and uses the first entry it finds as hostname, usually "localhost", unless you create the ORACLE_HOSTNAME environment variable prior to installing the software. If you change the hostname of the machine after the Oracle installation then the problem you described is very common.

                    Most people delete and recreate the EM repository, however there is a simple fix, which also allows you to keep the default 1158 TCP port address instead of 5500, for instance:
                    cd $ORACLE_HOME
                    ln -s localhost_$ORACLE_SID $ORACLE_HOSTNAME_$ORACLE_SID
                    cd $ORACLE_HOME/oc4j/j2ee
                    ln -s OC4J_DBConsole_localhost_$ORACLE_SID OC4J_DBConsole_$ORACLE_HOSTNAME_$ORACLE_SID
                    • 7. Re: wget error
                      Hi Dude:

                      I tried this but the problem is still there.

                      I did the following:

                      cd $ORACLE_HOME
                      ln -s localhost_$ORACLE_SID $ORACLE_HOSTNAME_$ORACLE_SID
                      cd $ORACLE_HOME/oc4j/j2ee
                      ln -s OC4J_DBConsole_localhost_$ORACLE_SID OC4J_DBConsole_$ORACLE_HOSTNAME_$ORACLE_SID

                      Is this ok? Do I need to restart the DB after these settings?

                      Please advice.

                      Thanks n regards,
                      • 8. Re: wget error
                        I even restarted the DB but still not able to start the em through https://localhost:1158/em