9 Replies Latest reply: Jun 12, 2013 9:15 PM by 5af33d20-a92e-4486-b505-437dd097f4fb RSS

    Upgrade to Apex 4

    738756
      Hi,

      I'm sure this question gets asked all the time but can someone point me to a simple guide on how to upgrade an xe instance to apex 4?

      The link I used before:

      http://www.oracle.com/technology/products/database/application_express/html/upgrade_apex_for_xe.html

      has been removed for some reason.

      Many Thanks,

      Darren.

      Edited by: Darren123 on 02-Oct-2010 09:57
        • 1. Re: Upgrade to Apex 4
          738756
          Okay so dispite the lack of Oracle documentation I've managed to upgrade by using several different internet sites.

          Here's how I did it incase anyone else is having similar frustrations (btw I'm on windows 7):

          1. Downloaded the latest oracle xe based on 10.2.0.1
          2. Installed it by running the exe
          3. Downloaded latest application express (4.0.1)
          4. unzipped the apex into c:\temp\ . Apex as it unzips creates it's own directory \apex .
          5. then change directory to that, ie cd c:\temp\apex
          6. run sqlplus as sysdba user ie type in at a command prompt: sqlplus system/+yourpassword+ as sysdba
          7. run the install script: @apexins SYSAUX SYSAUX TEMP /i/
          8. once this has installed it kicks you out of sqlplus so re log in ie sqlplus system/+yourpassword+ as sysdba
          9. move the new images in (the last parameter is the directory where you unzipped apex from, in this case temp) : @apxldimg.sql c:\temp
          10. lastly you need to set the admin password : @apxxepwd.sql password
          11. now log into apex in a browser: http://127.0.0.1:8080/apex/
          12. Workspace: internal
          13. username: admin
          14 password: password

          And that should work.

          Cheers,

          Darren

          Edited by: Darren123 on 02-Oct-2010 11:15
          • 2. Re: Upgrade to Apex 4
            809079
            Ciao Darren,
            I'm trying for the same. Thank you for your guide.
            Only a question for you. I have applications on my instance of Oracle XE, developed with APEX 2.0.
            How I can convert these to 4.0.1??
            Thank you

            Andrea
            • 3. Re: Upgrade to Apex 4
              jariola
              Hi,


              Install document say
              >
              If you have version 1.5.x, 1.6.x, 2.0.x, 2.2.x, 3.0.x, 3.1.x, or 3.2.x of Oracle Application Express, following any of the installation scenarios in this guide upgrades your Oracle Application Express instance to version 4.0 and creates Oracle Application Express 4.0 database objects in a new schema and migrates the application metadata to the new version.
              >

              You do not need convert anything.

              Regards,
              Jari
              • 4. Re: Upgrade to Apex 4
                809079
                Jari, I have read the documentation, but I would a feedback from users with an experience in this type of operation. In any case thank you for your report. I have taken a complete backup of my application and my data, in case of problems…
                Regards
                Andrea
                • 5. Re: Upgrade to Apex 4
                  809079
                  Done.... The procedure is OK, no problems encountered.
                  All applications runs fine after updating.
                  My system is Windows Vista SP2. Only to take care to select the right home. In my machine i have more Oracle Home, for updating i have choose the TNSPIGN installed with XE database.

                  Thanks and Regards

                  Andrea

                  Edited by: Andrea-Italy on 29-ott-2010 3.29
                  • 6. Re: Upgrade to Apex 4
                    jariola
                    Hi,

                    Ok, great !

                    As above post do not talk OWA_UTIL upgrade, did you do that also ?



                    Regards,
                    Jari

                    Edited by: jarola on Oct 29, 2010 5:10 PM
                    >
                    2.7 PL/SQL Web Toolkit

                    Oracle Application Express requires the PL/SQL Web Toolkit version 10.1.2.0.6 or later. For instructions on determining the current version of the PL/SQL Web Toolkit, and for instructions on installing version 10.1.2.0.6, please review the README.txt file contained in the directory apex/owa.
                    >
                    http://download.oracle.com/docs/cd/E17556_01/doc/install.40/e15513/pre_require.htm#BABGBJJD
                    • 7. Re: Upgrade to Apex 4
                      stevencallan
                      What was not clear here:
                      http://download.oracle.com/docs/cd/E17556_01/doc/install.40/e15513/overview.htm#insertedID2

                      And for 4.0.1:
                      The Oracle Application Express 4.0.1.00.03 patch set can be applied to Oracle Application Express release 4.0.0.00.46. Apply the patch to the Oracle database where the Oracle Application Express schemas are installed. This patch will determine if additional languages are installed, and will apply the patch for those languages as well. Oracle Application Express release 4.0.1 is supported on Oracle Database 10gR2 (10.2.0.3) and higher.
                      http://www.oracle.com/technetwork/developer-tools/apex/application-express/401-patch-166923.html

                      Did you upgrade the 10g database in your XE installation?
                      • 8. Re: Upgrade to Apex 4
                        jariola
                        Hi,

                        Latest install document for Apex version 4.0.1
                        >
                        2.1 Oracle Database Requirement

                        Oracle Application Express version 4.0 requires an Oracle database (Enterprise Edition, Standard Edition or Standard Edition One) that is release 10.2.0.3 or higher. Application Express 4.0 can also be used with Oracle Database 10g Express.
                        >

                        If you have installed 4.0, you can download patch from metalink and apply it to.
                        Patch 4.0.1.00.03 can be apply to XE database where is version Apex version 4.0.0.00.46 installed


                        Regards,
                        Jari
                        • 9. Re: Upgrade to Apex 4
                          5af33d20-a92e-4486-b505-437dd097f4fb

                          Hi,

                          I must upgrade Apex 3.1 to Apex 4.2 and I have many applications.

                          What can I do ?

                          I must export each workspace, export all applications, upgrade to Apex 4, import workspace, import all applications ?

                           

                          There is anybody can share his experience ?

                           

                          Thank you !