3 Replies Latest reply: Jul 19, 2013 2:40 AM by rdoogan RSS

    Client recertification hang


      When attempting to recertify a client using "obtool updatehost -r -f hostname", OSB only responds with "Info: waiting for host to update certification status...".  I have encountered this issue on hosts before, but normally a restart of the observiced daemon gets the client to recertify.  I have tried restarting observiced on the client.  I have tried reinstalling the OSB client.  I have checked to ensure that time is correct on both the client and server.


      OSB version is  Server is OEL 6.4.  Client is OEL 6.1.  Both x86_64.  Pinghost command returns (client hostname redacted with "clientname":

      Error: can't connect to Oracle Secure Backup service daemon on clientname - SSL fatal alert during negotation
      clientname:                   NDMP services are available


      What would be the recommended next steps for this?

        • 1. Re: Client recertification hang

          Have a look in the clients log files (/usr/tmp/observiced.log) to get an idea of why it is failing. Could be port conflict, firewall issue, something like that.





          • 2. Re: Client recertification hang

            /usr/tmp/observiced.log contains mainly this line:


            2013/07/18.20:12:12 unexpected certification failure! - observiced not running (OB connection mgr)
            2013/07/18.20:13:12 unexpected certification failure! - observiced not running (OB connection mgr)
            2013/07/18.20:14:12 unexpected certification failure! - observiced not running (OB connection mgr)
            2013/07/18.20:15:12 unexpected certification failure! - observiced not running (OB connection mgr)


            Interestingly, observiced *is* in fact running:


            # ps aux | grep observiced
            root     24332  0.1  0.0  49032  9280 ?        Ss   20:11   0:00 /usr/local/oracle/backup/.etc.linux86_64/observiced -b


            I have attempted stopping and then starting observiced via /etc/init.d/observiced.  I have also reinstalled OSB on this client, including completely removing the /usr/local/oracle/backup directory through the uninstall, but no change.


            What would be the next step?  Where can I find more information about the above error message from the log?

            • 3. Re: Client recertification hang

              So basically your client can't see your admin server. Do you have a firewall running on either machine that could be blocking the ports? Also does the client have multiple IPs configured on it, if so you will need ot list each one in the host configuration. Check "obtool lsh -l" to see how that is configured and also on the client do "cat /usr/etc/ob/.hostid" to see what the admin server IP shows. Make sure you can at least ping what is listed there. If you can try to telnet from the client to the admin server using ports 400 and 10000 to check if they are blocked.


              When you restart observiced also check the logfile to make sure the client says it is listening on ports 400 and 10000, and that nothing else is in the way.