3 Replies Latest reply: Jun 19, 2013 10:08 AM by Todd Little-Oracle RSS

    Problem With Tuxedo

    ildelian

      I have a recurrent problem when I try to connect with TUXEDO since WTC on Bea Weblogic.

       

      My Web App normally works fine but sometimes this error appears:

       

      ******* Run time exception information begins ****

      When: Fri May 10 13:04:03 CEST 2013

      Where: Calling RemoteService (SERVICE_NAME)

      What: TPException Why: TPETRAN - error starting transaction

      Subsystem code: 10016

      Error code: 10010099

      ******* Run time exception information ends  *****

      ******* Run time exception information begins ****

      When: Fri May 10 13:04:03 CEST 2013

      Where: Calling RemoteService (SERVICE_NAME)

      What: TPException Why: TPETRAN - error starting transaction

      Subsystem code: 10016

      Error code: 10010099

      ******* Run time exception information ends  *****


      The error disappears when you restart the server, but reappears after some time and I have to reset the server again.

       

      Sorry for my english  but i don't practise too much jeje.

       

      Thanks.

        • 1. Re: Problem With Tuxedo
          Todd Little-Oracle

          Hi,

           

          What is in the Tuxedo ULOG when this starts to happen?

           

          When you say restart "the server", which server are you referring to?  The Tuxedo server or WebLogic Server?

           

          Does the error only clear up when you restart "the server"?

           

          Regards,

          Todd Little

          Oracle Tuxedo Chief Architect

          • 2. Re: Problem With Tuxedo
            ildelian

            I have check the Tuxedo ULOG, and I see this message:

             

            132738.627.CLUSTER008!GWTDOMAIN.20973.1.0: gtrid x0 x51a0003e x1f3024:    LIBGW_CAT:1023: ERROR: Service request <SERVICE_NAME> from remote site <*********> failed:"TPETRAN - error starting transaction" gwerrno(402017)

             

            The server that i restar is the Weblogic Server.

             

            The errror only clear up when I restart the Weblogic server.

             

            Thanks for your help.

            • 3. Re: Problem With Tuxedo
              Todd Little-Oracle

              Hi,

               

              TPETRAN usually indicates that you tried to call a server that is not in a transactional group, i.e., has no TMS associated with it.  Are you saying that once you get this error, you continue to receive TPETRAN on subsequent requests until you restart WLS?

               

              On your Tuxedo system, can you check to see what server(s) is offering the SERVICE_NAME service and verify that the server is in a Tuxedo server group that has a TMS associated with it?

               

              Regards,

              Todd Little

              Oracle Tuxedo Chief Architect