5 Replies Latest reply: Jun 18, 2013 2:48 PM by Kosta-Oracle RSS

    Problem installing jrebel plugin

    user9503787

      I have oepe that bundled with weblogic portal 10.3.4. I tried to install JRebel plugin, I have "Contact all update sites during install to find required software" checked, but got the error. what I missed? how can I get it? Thanks!

       

      Cannot complete the install because one or more required items could not be found.

      Software currently installed: Eclipse Web Developer Tools 3.2.2.v201008100100-7O7CFbKEMf84nUlEJyX7-SPQjhYZ (org.eclipse.wst.web_ui.feature.feature.group 3.2.2.v201008100100-7O7CFbKEMf84nUlEJyX7-SPQjhYZ)

      Missing requirement: WST Server Core 3.2.2.v20100908-30F8V8s734C3I3K (org.eclipse.wst.server_core.feature.feature.group 3.2.2.v20100908-30F8V8s734C3I3K) requires 'org.eclipse.wst.server.core [1.1.204.v20100908]' but it could not be found

      Cannot satisfy dependency:

      From: WST Web Core 3.2.2.v201008100100-7E7AFHwAJrn5PM15pUYBwJLkSG8j (org.eclipse.wst.web_core.feature.feature.group 3.2.2.v201008100100-7E7AFHwAJrn5PM15pUYBwJLkSG8j)

      To: org.eclipse.wst.server_core.feature.feature.group [3.2.2.v20100908-30F8V8s734C3I3K]

      Cannot satisfy dependency:

      From: Eclipse Web Developer Tools 3.2.2.v201008100100-7O7CFbKEMf84nUlEJyX7-SPQjhYZ (org.eclipse.wst.web_ui.feature.feature.group 3.2.2.v201008100100-7O7CFbKEMf84nUlEJyX7-SPQjhYZ)

      To: org.eclipse.wst.web_core.feature.feature.group [3.2.2.v201008100100-7E7AFHwAJrn5PM15pUYBwJLkSG8j]

        • 1. Re: Problem installing jrebel plugin
          Kosta-Oracle

          What do you get if you try installing with "Contact all update sites during install to find required software" option turned off?

          • 2. Re: Problem installing jrebel plugin
            user9503787

            Thank you. After I unckeck the check box, jrebel install is finished without error. However after I restart oepe, I cannot clean / build any of the projects. There are a lot errors for plugin. Here is one of them:

             

            eclipse.buildId=M20100909-0800

            java.version=1.6.0_22

            java.vendor=Oracle Corporation

            BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

            Command-line arguments:  -data C:\develCBP\CBPApp -os win32 -ws win32 -arch x86

             

            Error

            Tue Jun 18 12:05:04 PDT 2013

            Problems occurred when invoking code from plug-in: "org.eclipse.ui.navigator".

             

            java.lang.ArrayIndexOutOfBoundsException: 52

              at org.eclipse.emf.common.util.BasicEList.contains(BasicEList.java:172)

              at org.eclipse.jst.jee.model.internal.JEE5ModelProvider.addManagedResource(JEE5ModelProvider.java:129)

              at org.eclipse.jst.jee.model.internal.JEE5ModelProvider.getModelResource(JEE5ModelProvider.java:172)

              at org.eclipse.jst.jee.model.internal.EAR5ModelProvider.getModelObject(EAR5ModelProvider.java:53)

              at org.eclipse.jst.j2ee.project.EarUtilities.getEARLibDir(EarUtilities.java:430)

              at org.eclipse.jst.j2ee.internal.common.classpath.J2EEComponentClasspathContainer.getBaseEARLibRefs(J2EEComponentClasspathContainer.java:315)

              at org.eclipse.jst.j2ee.internal.common.classpath.J2EEComponentClasspathContainer.update(J2EEComponentClasspathContainer.java:208)

              at org.eclipse.jst.j2ee.internal.common.classpath.J2EEComponentClasspathContainer.install(J2EEComponentClasspathContainer.java:382)

              at org.eclipse.jst.j2ee.internal.common.classpath.J2EEComponentClasspathInitializer.initialize(J2EEComponentClasspathInitializer.java:48)

              at org.eclipse.jdt.internal.core.JavaModelManager.initializeContainer(JavaModelManager.java:2707)

              at org.eclipse.jdt.internal.core.JavaModelManager.getClasspathContainer(JavaModelManager.java:1850)

              at org.eclipse.jdt.core.JavaCore.getClasspathContainer(JavaCore.java:2705)

            ...

            • 3. Re: Problem installing jrebel plugin
              Kosta-Oracle

              Since the failure only surfaced after you installed JRebel, please follow up with that product's support.

              • 4. Re: Problem installing jrebel plugin
                user9503787

                I have jrebel plugin working fine before all the time on different machines. The installation issue happens for a new X230 laptop. I wonder I missed anything after I unchecked the option and caused the installation is not complete?

                • 5. Re: Problem installing jrebel plugin
                  Kosta-Oracle

                  Regardless, you've exhausted the extent to which we can help you with this problem.