This discussion is archived
5 Replies Latest reply: Jun 24, 2013 4:27 AM by tapas_05 RSS

yum install issue

tapas_05 Newbie
Currently Being Moderated

Hi OEL Experts,

I am trying to install glibc.i686 on my OEL 6 x86 64bit machine, got below error:

 

[root@oeltux ~]# yum install glibc.i686

Loaded plugins: refresh-packagekit, security

http://linuxdownload.adobe.com/linux/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"

Trying other mirror.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: adobe-linux-x86_64. Please verify its path and try again

 

Below is my OS environment:

[root@oeltux ~]# cat /etc/issue

Oracle Linux Server release 6.4

Kernel \r on an \m

 

[root@oeltux ~]# uname -a

Linux oeltux.idc.oracle.com 2.6.39-300.28.1.el6uek.x86_64 #1 SMP Tue Feb 5 22:51:31 PST 2013 x86_64 x86_64 x86_64 GNU/Linux

 

Your help will be really appreciated.

Thanks,

Tapas

  • 1. Re: yum install issue
    Dude! Guru
    Currently Being Moderated

    It seems you your YUM repository configuration is not setup properly. I suggest to check the content of /etc/yum.repos.d/. Since your hostname "oeltux.idc.oracle.com" suggest you are working at Oracle, you might rather want to get in touch with internal support. Otherwise instructions provided at  http://public-yum.oracle.com/ should work too.

  • 2. Re: yum install issue
    BillyVerreynne Oracle ACE
    Currently Being Moderated

    Perhaps you need to use your corporate web proxy for accessing Internet web sites? This is fairly common.

     

    As root, export the following 2 environment variables:

    export http_proxy=http://<username>:<password>@proxy.mydomain:com:<port>

    export https_proxy=https://<username>:<password>@proxy.mydomain:com:<port>

     

    The <username>:<password>@ part is optional (proxy authentication for when the proxy server does not allow anonymous access).

     

    I usually create a .proxy file in /root as follows:

    export http_proxy=http://scott:tiger@proxy.mydomain:com:8080
    export https_proxy=https://scott:tiger@proxy.mydomain:com:8080

     

    And then source it as follows (either from bash command line, or in bash_profile):

    . /root/.proxy

  • 3. Re: yum install issue
    TommyReynolds Expert
    Currently Being Moderated

    Here is how to check that you have access to the Oracle update servers:

     

    1)   First, see if a direct connection is possible:

     

        # /usr/bin/nc linux-update.oracle.com 443

     

    Then check if we have access through the proxy:

     

        # /usr/bin/nc -X http -x 192.168.10.253:80 linux-update.oracle.com 443

     

    Replace 192.168.10.253:80 with your corporate proxy information.

     

    Once that succeeds, you can add the line:

     

            proxy=http://<your-proxy-host>:<your-proxy-port>

     

    to the /etc/yum.conf file.  Then you can just:

     

        # yum update

     

    to your heart's content.

  • 4. Re: yum install issue
    WadhahDAOUEHI Journeyer
    Currently Being Moderated

    Hi,

    1. Fist verify your internet connection (ping any website)
    • If you have dhcp server (verify the GATEWAY Address and DNS Address)
    • If static configuration
      • FIX IP Address in the file /etc/sysconfig/network-scripts/ifcfg-eth0   
      • FIX GATEWAY Address in the file /etc/sysconfig/network
      • FIX DNS Address in the file /etc/resolv.conf

         => Now verify your connection

         2. Second verify your YUM repository configuration. (it's like Dude sed)

    It seems you your YUM repository configuration is not setup properly. I suggest to check the content of /etc/yum.repos.d/. Since your hostname "oeltux.idc.oracle.com" suggest you are working at Oracle, you might rather want to get in touch with internal support. Otherwise instructions provided at http://public-yum.oracle.com/ should work too.

    and your system use the uek6.

    [root@oeltux ~]# uname -a

    Linux oeltux.idc.oracle.com 2.6.39-300.28.1.el6uek.x86_64 #1 SMP Tue Feb 5 22:51:31 PST 2013 x86_64 x86_64 x86_64 GNU/Linux

    Verify that /etc/yum.repo.d/public-yum-ol6.repo looks like:

    .....

    [ol6_UEK_latest]

    name=Latest Unbreakable Enterprise Kernel for Oracle Linux $releasever ($basearch)

    baseurl=http://public-yum.oracle.com/repo/OracleLinux/OL6/UEK/latest/$basearch/

    gpgkey=http://public-yum.oracle.com/RPM-GPG-KEY-oracle-ol6

    gpgcheck=1

    enabled=1

    .....

     

    I hope this can help you

    Best Regards

     

    Message was edited by: WadhahDAOUEHI [correct word]

  • 5. Re: yum install issue
    tapas_05 Newbie
    Currently Being Moderated

    I have changed the yum repository and now it is working without any issue, the new one is ULN-Base.repo and below is the UEK entry:

    [ol6_UEK_latest]

    name=Latest Unbreakable Enterprise Kernel for Oracle Linux $releasever ($basearch)

    baseurl=http://uln-internal.oracle.com/uln/OracleLinux/OL6/UEK/latest/$basearch/

    gpgcheck=1

    enabled=0

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points