1 Reply Latest reply: Jun 24, 2013 10:51 PM by sb92075 RSS

    could not resolve the conect identifier specified XE

    956118

      HI  I am using toad to connect to oracle .

       

      I have installed the 10g express edition on my laptop and using toad to connect to  it and do my work.

       

      The problem i am facing is when ever i try to connect through TOAD ,it says that could not resolve the connect identifier specified (XE).

       

      But i checked the tnsnames.ora entry and it looks fine.

       

      In fact i used plsqlsql developer and it is able to connect  with out any problem .

      But i am used to the tool toad and hence want to use toad .why this error is occuring only in TOAD.

       

       

      when i click on tnsnameseditor in toad ,it sows correct tnsfile and it ays the entry is valid.

      when i click on SQLNET editor ,there i see following parameters.

       

       

       

      # This file is actually generated by netca. But if customers choose to

      # install "Software Only", this file wont exist and without the native

      # authentication, they will not be able to connect to the database on NT.

       

       

       

       

      # The following parameters were set by TOAD

      SQLNET.AUTHENTICATION_SERVICES=(NTS)

      LOG_DIRECTORY_CLIENT=D:\oracle10G\app\oracle\product\10.2.0\server\Network\Log

      LOG_FILE_CLIENT=sqlnet_log

      SQLNET.EXPIRE_TIME=0

      TRACE_DIRECTORY_CLIENT=D:\oracle10G\app\oracle\product\10.2.0\server\Network\Trace

      TRACE_FILE_CLIENT=sqlnet_trc

      TRACE_FILELEN_CLIENT=100

      TRACE_FILENO_CLIENT=3

      TRACE_LEVEL_CLIENT=OFF

      TRACE_TIMESTAMP_CLIENT=ON

      TRACE_UNIQUE_CLIENT=ON

      USE_DEDICATED_SERVER=OFF

       

       

      I tried uninstalling both oracle and toad and tried ,but the same annoying error .

       

      Any help is much appreciated.

        • 1. Re: could not resolve the conect identifier specified XE
          sb92075

          ORA-12154 ALWAYS only occurs on SQL Client & no SQL*Net packets ever leave client system

          ORA-12154 [B]NEVER[/B] involves the listener, the database itself or anything on the DB Server.

          ORA-12154 occurs when client requests a connection to some DB server system using some connection string.

          TNS-03505 is thrown by tnsping & is same error as ORA-12154 thrown by sqlplus or others.

          The lookup operation fails because the name provided can [B]NOT[/B] be resolved to any remote DB.

          The analogous operation would be when you wanted to call somebody, but could not find their name in any phonebook.

          The most frequent cause for the ORA-12154  error is when the connection alias can not be found in tnsnames.ora.

          The lookup operation of the alias can be impacted by the contents of the sqlnet.ora file; specifically DOMAIN entry.

          TROUBLESHOOTING GUIDE: ORA-12154 & TNS-12154 TNS:could not resolve service name [ID 114085.1]

          http://edstevensdba.wordpress.com/2011/02/26/ora-12154tns-03505/