0 Replies Latest reply: Jun 25, 2013 4:09 PM by LosLobo RSS

    Jar confusion


      Folks, lets say I'm compiling my java code with version 1.6.

      Now I'm including a large base of jar files doing all kinds of things including xml parsing, pdf rendering, web services, etc. etc.

      Now all of a sudden on one of the environments I'm getting one of these lovely things at Runtime(IllegalAccessError):

      The description of IllegalAccessError in the API documentation says:
      Thrown if an application attempts to access or modify a field, or to call a method that it does not have access to.
      Normally, this error is caught by the compiler; this error can only occur at run time if the definition of a class has incompatibly changed.

      OK, so with all these cute little jar files I have no idea which version of the JDK they were using.

      But I am getting this error at Runtime.  My question is this:

      I'm compiling with java 1.6, I have no idea what jdk version was used for each and every myriad of jars I am referencing.

      Is this a problem?

      If it is how do I resolve this?