5 Replies Latest reply: Jun 26, 2013 2:18 PM by jstem1177 RSS

    install or configure current?

    Ingenio
      hi!
      I have an FMW installation running ok from 2 years ago for my forms/reports application.
      now I need to run a little PHP app from the same server, but Im not really clear with this.
      I just tried configure the OHS for PHP using thisinstructions: http://www.oracle.com/technetwork/topics/php/php-ohs-092324.html
      I need to know if its posible keeping my current functionality, or if I need to install a new OHS as from http://www.oracle.com/technetwork/java/webtier/downloads/index-jsp-156711.html



      setting the variables:

      #!/bin/sh
      ORACLE_HOME=/opt/oracle/Middleware/as_1
      ORACLE_INSTANCE=/opt/oracle/Middleware/asinst_1
      CONFIG_FILE_PATH=/opt/oracle/Middleware/asinst_1/config/OHS/ohs1
      LD_LIBRARY_PATH=/opt/oracle/Middleware/as_1/lib:/opt/oracle/Middleware/as_1/ohs/lib:$ LD_LIBRARY_PATH
      export ORACLE_HOME ORACLE_INSTANCE CONFIG_FILE_PATH LD_LIBRARY_PATH

      but the error:

      [oracle@web php-5.4.13]$ ./configure with-apxs2=$ORACLE_HOME/ohs/bin/apxs prefix=$ORACLE_HOME --with-config-file-path=$CONFIG_FILE_PATH
      checking for grep that handles long lines and -e... /bin/grep
      checking for egrep... /bin/grep -E
      checking for a sed that does not truncate output... /bin/sed
      checking build system type... i686-pc-linux-gnu
      checking host system type... i686-pc-linux-gnu
      checking target system type... i686-pc-linux-gnu
      checking for cc... cc
      checking for C compiler default output file name... a.out
      checking whether the C compiler works... yes
      checking whether we are cross compiling... no
      checking for suffix of executables...
      checking for suffix of object files... o
      checking whether we are using the GNU C compiler... yes
      checking whether cc accepts -g... yes
      checking for cc option to accept ISO C89... none needed
      checking how to run the C preprocessor... cc -E
      checking for icc... no
      checking for suncc... no
      checking whether cc understands -c and -o together... yes
      checking how to run the C preprocessor... cc -E
      checking for AIX... no
      checking whether ln -s works... yes
      checking for system library directory... lib
      checking whether to enable runpaths... yes
      checking if compiler supports -R... no
      checking if compiler supports -Wl,-rpath,... yes
      checking for gawk... gawk
      checking for bison... bison -y
      checking for bison version... 2.3 (ok)
      checking for re2c... no
      configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
      checking whether to enable computed goto gcc extension with re2c... no
      checking whether to force non-PIC code in shared modules... yes
      checking whether /dev/urandom exists... yes
      checking for pthreads_cflags... -pthread
      checking for pthreads_lib...

      Configuring SAPI modules
      checking for AOLserver support... no
      checking for Apache 1.x module support via DSO through APXS... no
      checking for Apache 1.x module support... no
      checking whether to enable Apache charset compatibility option... no
      checking for Apache 2.0 filter-module support via DSO through APXS... no
      checking for Apache 2.0 handler-module support via DSO through APXS...

      Sorry, I cannot run apxs. Possible reasons follow:

      1. Perl is not installed
      2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
      3. Apache was not built using --enable-so (the apxs usage page is displayed)

      The output of /opt/oracle/Middleware/as_1/ohs/bin/apxs follows:
      /opt/oracle/Middleware/as_1/ohs/bin/httpd: error while loading shared libraries: libdms2.so: cannot open shared object file: No such file or directory
      apxs:Error: Sorry, no DSO support for Apache available
      apxs:Error: under your platform. Make sure the Apache
      apxs:Error: module mod_so is compiled into your server
      apxs:Error: binary `/opt/oracle/Middleware/as_1/ohs/bin/httpd'.
      configure: error: Aborting
      [oracle@web php-5.4.13]$ ./configure with-apxs2=$ORACLE_HOME/ohs/bin/apxs prefix=$ORACLE_HOME --with-config-file-path=$CONFIG_FILE_PATH
      checking for grep that handles long lines and -e... /bin/grep
      checking for egrep... /bin/grep -E
      checking for a sed that does not truncate output... /bin/sed
      checking build system type... i686-pc-linux-gnu
      checking host system type... i686-pc-linux-gnu
      checking target system type... i686-pc-linux-gnu
      checking for cc... cc
      checking for C compiler default output file name... a.out
      checking whether the C compiler works... yes
      checking whether we are cross compiling... no
      checking for suffix of executables...
      checking for suffix of object files... o
      checking whether we are using the GNU C compiler... yes
      checking whether cc accepts -g... yes
      checking for cc option to accept ISO C89... none needed
      checking how to run the C preprocessor... cc -E
      checking for icc... no
      checking for suncc... no
      checking whether cc understands -c and -o together... yes
      checking how to run the C preprocessor... cc -E
      checking for AIX... no
      checking whether ln -s works... yes
      checking for system library directory... lib
      checking whether to enable runpaths... yes
      checking if compiler supports -R... no
      checking if compiler supports -Wl,-rpath,... yes
      checking for gawk... gawk
      checking for bison... bison -y
      checking for bison version... 2.3 (ok)
      checking for re2c... no
      configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
      checking whether to enable computed goto gcc extension with re2c... no
      checking whether to force non-PIC code in shared modules... yes
      checking whether /dev/urandom exists... yes
      checking for pthreads_cflags... -pthread
      checking for pthreads_lib...

      Configuring SAPI modules
      checking for AOLserver support... no
      checking for Apache 1.x module support via DSO through APXS... no
      checking for Apache 1.x module support... no
      checking whether to enable Apache charset compatibility option... no
      checking for Apache 2.0 filter-module support via DSO through APXS... no
      checking for Apache 2.0 handler-module support via DSO through APXS...

      Sorry, I cannot run apxs. Possible reasons follow:

      1. Perl is not installed
      2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
      3. Apache was not built using --enable-so (the apxs usage page is displayed)

      The output of /opt/oracle/Middleware/as_1/ohs/bin/apxs follows:
      /opt/oracle/Middleware/as_1/ohs/bin/httpd: error while loading shared libraries: libdms2.so: cannot open shared object file: No such file or directory
      apxs:Error: Sorry, no DSO support for Apache available
      apxs:Error: under your platform. Make sure the Apache
      apxs:Error: module mod_so is compiled into your server
      apxs:Error: binary `/opt/oracle/Middleware/as_1/ohs/bin/httpd'.
      configure: error: Aborting

      thanks a lot!
        • 1. Re: install or configure current?
          cj
          Do you have libdms2.so anywhere? If so, include it in your LD_LIBRARY_PATH.
          I can see some references to it in the doc: http://docs.oracle.com/cd/B14099_19/core.1012/b14001/dms.htm#CIHJCDGB

          Regarding installation instructions, the link you refer to is slightly out of date. In particular regarding the header files it uses
          old ones. Instead, check out the instructions from p.86 of http://www.oracle.com/technetwork/topics/php/underground-php-oracle-manual-098250.html
          There are sets of instructions for versions 10 & 11.
          • 2. Re: install or configure current?
            Ingenio
            CJ,
            I realized there was a space on the variables, then it installed very well..

            thanks!
            • 3. Re: install or configure current?
              jstem1177

              Hello,


              Its does not seem APXS  "invalid Query string" issue is fixed. I'm trying to configure PHP 5.4.16 on OHS 11g.

              The reason I seems is because errors are thrown but it passes off as yes for APXS. I've put the fix for APEX_VERSION decribed in (http://www.oracle.com/technetwork/topics/php/201212-ug-php-oracle-1884760.pdf) and its still does not work.

              Due to the error I'm holding off on the make and make install, until I can get some sort of answer and fix into place.

               

               

              #> cd /home/oraweb/php-5.2.15
              #> ./configure --with-apxs2=$ORACLE_HOME/ohs/bin/apxs --prefix=$ORACLE_HOME --with-config-file-path=$CONFIG_FILE_PATH --with-oci8=$ORACLE_HOME --with-libxml-dir=/usr/lib --disable-rpath
              
              
              

               

               

               

              [.....]
              Configuring SAPI modules
              checking for AOLserver support... no
              checking for Apache 1.x module support via DSO through APXS... no
              checking for Apache 1.x module support... no
              checking whether to enable Apache charset compatibility option... no
              checking for Apache 2.0 filter-module support via DSO through APXS... no
              checking for Apache 2.0 handler-module support via DSO through APXS... apxs:Error: Invalid query string `BINDIR'
              apxs:Error: Invalid query string `APU_BINDIR'
              apxs:Error: Invalid query string `APR_BINDIR'
              ./configure: line 8000: /apr-config: No such file or directory
              ./configure: line 8001: /apu-config: No such file or directory
              expr: non-numeric argument
              ./configure: line 8022: test: : integer expression expected
              ./configure: line 8026: test: : integer expression expected
              ./configure: line 8748: test: : integer expression expected
              yes
              
              
              

               

               

              #> /u01/app/oracle/middleware/webtier_1/ohs/bin/httpd.worker -version
              Server version: Oracle-HTTP-Server/2.2.21 (Unix)
              Server built:   Nov 19 2011 01:19:35
              Server label:   APACHE_11.1.1.6.0_LINUX.X64_111109.2001
              
              
              

               

              I have also checked and it seems that the mod_so was proprely configured with OHS

               

              #> /u01/app/oracle/middleware/webtier_1/ohs/bin/httpd.worker -l
              Compiled in modules:
                core.c
                worker.c
                http_core.c
                mod_so.c
                odl_log.c
                ohs_core.c
                ora_audit.c
              

               

               

              So the big question remains are these just error that can be ignore because of a failed echo because paths do not exists and something is wrong with the string test for Apache 2.1>

              
               8000   APR_CFLAGS="`$APR_CONFIG --cppflags --includes`"
                8001   APU_CFLAGS="`$APU_CONFIG --includes`"
                8019
                8020   APACHE_VERSION=`expr $6 \* 1000000 + $7 \* 1000 + $8`
                8021
                8022   if test "$APACHE_VERSION" -le 2000000; then
                8023     { { echo "$as_me:$LINENO: error: You have enabled Apache 2 support while your server is Apache 1.3.  Please use the appropiate switch --with-apxs (without the 2)" >&       5
                8024 echo "$as_me: error: You have enabled Apache 2 support while your server is Apache 1.3.  Please use the appropiate switch --with-apxs (without the 2)" >&2;}
                8025    { (exit 1); exit 1; }; }
                8026   elif test "$APACHE_VERSION" -lt 2000044; then
                8027     { { echo "$as_me:$LINENO: error: Please note that Apache version >= 2.0.44 is required" >&5
                8028 echo "$as_me: error: Please note that Apache version >= 2.0.44 is required" >&2;}
                8029    { (exit 1); exit 1; }; }
              
              
              
              

               

              I think the APU and APR and the above errors can be SAFELY IGNORED.

              Thanks in advance.


              Jan S.

              • 4. Re: install or configure current?
                jstem1177

                So I have PHP up and running, still debugging some OCI stuff however I did want to brings this up.

                 

                With Firebug (firefox debug tool) I see that the Server is Oracle-Application-Server-11g, not sure if this would have any effects on the previous thread errors.


                Jan S.

                • 5. Re: install or configure current?
                  jstem1177

                  Use full note for APXS errors

                  Configuring PHP with Oracle HTTP Server 11g [ID 1163665.1]