This discussion is archived
5 Replies Latest reply: Jun 27, 2013 7:33 PM by Hemant K Chitale RSS

Fail in copy from ASM to remote ASM

XerXi Newbie
Currently Being Moderated

Hello. I am trying to transfer my backups directly through asm on a remote machine, but doesn't work. Here's what I do:

ASMCMD [+fra/eni/backupset/2013_06_27] > cp ncnnf0_TAG20130627T110321_0.272.819198229 sys@sdbora2.1525.+ASM:+FRA/bla

 

The source machine is running a listener on port 1521. The remote is on 1525. TNS connection works between machines. I turned on DBI_TRACE and here is the output:

 

-> DBI->connect(dbi:Oracle:host=sdbora2.1525;port=1521;sid=+ASM, sys, ****, HASH(0x9c57470))

connect using '(DESCRIPTION=(ADDRESS=(HOST=sdbora2.1525)(PROTOCOL=tcp)(PORT=1521))(CONNECT_DATA=(SID=+ASM)))'    !! ERROR: '12545' 'ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)' (err#0)

    <- connect('host=sdbora2.1525;port=1521;sid=+ASM', 'sys', ...)= undef at DBI.pm line 637

       DBI connect('host=sdbora2.1525;port=1521;sid=+ASM','sys',...) failed: ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)

ASMCMD-8201: (Bad argc for RDBMS:ASMCMD-8201)

    <- disconnect= 1 at asmcmdbase.pm line 4734

    -> DBI->connect(dbi:Oracle:, , ****, HASH(0x9c57470))

    !! ERROR: '12545' CLEARED by call to default_user method

    <- default_user(undef, undef, ...)= ( undef undef ) [2 items] at DBI.pm line 625

    <- DESTROY(DBI::st=HASH(9dc2000))= undef at Oracle.pm line 234

    <- connect('', undef, ...)= DBI::db=HASH(0x9dc21f8) at DBI.pm line 637

    <- STORE('PrintError', 0)= 1 at DBI.pm line 689

    <- STORE('AutoCommit', 1)= 1 at DBI.pm line 689

    <- STORE('Username', undef)= 1 at DBI.pm line 692

    <> FETCH('Username')= undef ('Username' from cache) at DBI.pm line 692

$h->{'ora_session_mode'}=32768 ignored for invalid driver-specific attribute

    <- STORE('ora_session_mode', 32768)= '' at DBI.pm line 692

    <- FETCH('ora_session_mode')= undef at DBI.pm line 692

    <- connected('dbi:Oracle:', undef, ...)= undef at DBI.pm line 698

    <- connect= DBI::db=HASH(0x9dc21f8)

    <- STORE('dbi_connect_closure', CODE(0x9dc2480))= 1 at DBI.pm line 707

    <- DESTROY(DBI::db=HASH(9cc7b00))= undef at asmcmdcore line 589

 

It seems it doesn't catch  that I specify port 1525. Help, please. Thank you.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points