0 Replies Latest reply: Jul 1, 2013 10:28 AM by karthiksingh_dba RSS

    Steps to Convert OEL 5.7 vmdk to amazon ec2 ami

    karthiksingh_dba

      Dear Legends,

       

      I request you to provide me or guide me some steps to convert my existing OEL vmdk to import into amazon ec2. The following are my tries

      1. Installed a fresh OEL 5.7 64bit, while installing I enabled KVM option and installed Xen kernel rpm (kernel-xen-2.6.18-348.el5.x86_64)

      2. After installation of O/s Edited /boot/grub.conf as follows

      default 0

      timeout 5

      title OEL

      root (hd0)

      kernel /boot/vmlinuz-2.6.18-348.el5xen ro root=/dev/sda1

      initrd /boot/initrd-2.6.18-348.el5xen.img

      3. Edited the /etc/fstab

      /dev/sda1 / ext3 defaults 1 1

      /dev/sdb /mnt ext3 defaults 0 0

      4. Shutdown the O/s and converted the vmdk to raw using qemu-img convert as suggested in Creating a new EC2 AMI from within VMware or from VMDK files – UK Ruby on Rails, Exalead, AWS, Consultancy

      5. Tried to launch my instance from Amazon using

      - m1.small

      - m1.medium

      - m1.large

      tried above said three different options but No use. Because I'm able to get a status of instance as RUNNING but out of 2 status checks it passed only 1. The complete error log is here https://forums.aws.amazon.com/thread.jspa?threadID=125180

       

      Please guide me where I'm doing wrong. I'm breaking my heads for the past 4 months. I'm able to launch a New AMI but I need to know where I'm making mistake and will learn things to resolve this issue.

      Any kind of help would be much appreciated.

      Thanks,

      Karthik