0 Replies Latest reply on Jul 5, 2013 3:35 AM by lsgroup

    build on smartos xqilla problem,fails


      when building berkely bdxml, build script fails during xqilla build. 


      make[1]: *** [DatatypeLookup.lo] Error 1

      make[1]: Leaving directory `/home/nxd/store/dbxml-2.5.16/xqilla/build'

      make: *** [all-recursive] Error 1


      ./xqilla/build/config.log does not indicate anything after the configure - which exits 0 (successful). 


      I even tried this invocation:

      bash ./buildall.sh -c gcc -x g++ --with-configure-env="CFLAGS='-m64 -mcpu=v9' CXXFLAGS='-m64 -mcpu=v9 -L$PWD/install/lib' LDFLAGS='-m64 -mcpu=v9 -L$PWD/install/lib'"


      I also tried going into the xqilla area and building just xqilla, same problem:


      ../configure --with-xerces=../../xerces-c-src/


      and also:


      export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/ccs/lib/:/usr/ccs/lib/amd64/lib/

      ../configure --with-xerces=../../xerces-c-src/ LDFLAGS="-L/usr/ccs/lib:/usr/ccs/lib/amd64/lib"


      Can't seem to fix this one.  Anyone have any ideas?