10 Replies Latest reply: Jul 17, 2013 11:13 PM by pkpanda RSS

    Enkitec > Modal LOV > Problem on Theme 25 ?

    itobinh

      I have used the great Enkitec Modal LOV with my application using theme 25 (responsive).

       

      First problem:

      The Modal LOV just showing one page only event I have more data than only one page.

      For the comparison, I have no problem with "Super LOV".

       

      Second problem:

      There is additional unwanted column at the end right column called "Total_Rows".

       

      Any body knows how to solve this problems ?

       

      Many thanks!

        • 1. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
          itobinh

          Any one can helps ?

          • 2. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
            dmcghan

            Hello itobinh,

             

            You must be using APEX 4.2.1. In that version there was a bug in one of the plug-in APIs that added an unwanted column. The only workaround I know of is to use the hidden columns feature of the plug-in. Count the total number of columns in your query and then add one. Make that column hidden.

             

            Of couse another option is to upgrade to the latest patch set.

             

            Or if you can wait, I'm doing a round of bug fixing and I can address the issue in the next release. Hopefully that will be out later this week.

             

            Regards,

            Dan

            • 3. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
              dmcghan

              itobinh,

               

              Could you show me the results of the following query:

              SELECT *

              FROM apex_release

               

              Regards,

              Dan

              • 4. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
                pkpanda

                I have found one more but for the same template

                 

                the LOV 'open dialog' and 'clear content' button are not displaying properly in modal, show and hide region template. Also if you use jquery tabs it has the same problem. I check the item style and found it is reducing the height to 9.89px instant of 25px in other template

                 

                thanks PP

                • 5. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
                  dmcghan

                  Hi PP,

                   

                  Hmmm. That doesn't sound good!

                   

                  I was hoping to keep a consistent code path through all APEX releases but I may have to fork 4.2 to fix that. Could you do me a favor and set up some tests on apex.oracle.com that show the issues?

                   

                  Maybe I'll get lucky with a slight CSS modification.

                   

                  Regards,

                  Dan

                  • 6. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
                    dmcghan

                    PP,

                     

                    Actually I was able to replicate with a quick test. Now that I think about it, this kinda makes sense. When the page is loading the plug-in attempts to measure the size of the input and adjust the height of the buttons to match.

                     

                    When you have a region type that renders with the display set to none, then there really is no height and with so it gets it wrong. The best workaround for this would be to manually set the height right after you show the region.

                     

                    So lets say you've run the page before switching the region template to one that's hidden when the page renders and determined that the correct size of the buttons is "26px". You could add an Execute JavaScript dynamic action right after the show action with something like this:

                    jQuery('#PX_ITEM_NAME_fieldset div.ui-buttonset > button').css('height', '26px');

                     

                    The only parts you need to update are the item name one the left and the size on the right.

                     

                    Let me know if that works for you.

                     

                    Regards,

                    Dan

                    • 7. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
                      itobinh

                      Hi Dan,

                       

                      Thanks for the reply.

                       

                      I will check it further after back to the office next week.

                       

                      Thanks a lot.

                       

                      Rgds,

                      Tobin

                      • 8. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
                        itobinh

                        Hi Dan,

                         

                        Thanks for your help.

                         

                        I can hide the unnecessary column by hiding it.

                         

                        Yes, you are right. I am using Apex 4.2.1.

                         

                        Another problem is why the search function is so slow almost unusable for my case.

                         

                        Rgds,

                        Tobin

                        • 9. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
                          dmcghan

                          Tobin,

                           

                          The bug regarding the extra column has been fixed in the latest release of the plug-in (along with some other bugs).

                           

                          Also, in the latest release of the plug-in I've exposed the Search Type so that you can configure it. If you're going agains a large data set it may help. Check the documentation for notes.

                           

                          Regards,

                          Dan

                          • 10. Re: Enkitec > Modal LOV > Problem on Theme 25 ?
                            pkpanda

                            Hi,

                            Sorry for the delay. I tried and it works. I will try and make it more generic so that I don't have to use it after every show action.