This discussion is archived
4 Replies Latest reply: Jul 5, 2013 6:38 AM by Jurii Banin RSS

Error while trying to Initialize endeca project in CIM

Jurii Banin Newbie
Currently Being Moderated
Hello

Here is a log that IMO contains necessary information:

[exec] Importing media...
[exec] 'D:\ATGT\Env\Endeca\Apps\CRS\control\set_media.bat' is not recognized as an internal or external command,
[exec] operable program or batch file.

Actually there is no such file. Can anyone explain, when it should be created and how can I resolve this issue? I'm using ATG Commerce Reference Store Installation and Configuration Guide and doing everything step-by-step according to this guide.
ATG version: 10.1.2
Endeca Tools: 3.1.1
Endeca Platform Services: 6.1.3
MDEX: 6.4.0

Thanks,
Jurii
  • 1. Re: Error while trying to Initialize endeca project in CIM
    cmore Explorer
    Currently Being Moderated
    Did you run the deployment by hand, or have CIM do it?

    I've seen a minimal Endeca app created when I incorrectly specified the deployment template. Once, for example, I typed "-app" rather than "--app" (one dash rather than two) as a deploy script argument. The deploy script seemed to run correctly and it did create an application... but it lacked all the specifics added by my deployment template (including scripts like set_media).
  • 2. Re: Error while trying to Initialize endeca project in CIM
    AkinRaj Newbie
    Currently Being Moderated

    Hello folks,

    I'm having the same issue too, I'm using CIM to deploy..

    Can someone throw any help on this please..

    Thanks,

    Raj

  • 3. Re: Error while trying to Initialize endeca project in CIM
    noname2inc Newbie
    Currently Being Moderated

    Hello All!

    I faced the same. My issue was in using gs.zip (Oracle Endeca Guided Search) as Tools and Frameworks. I stoped this service and uninstalled it. Then installed xmgr.zip (Oracle Endeca Experienced Manager) and ran it. After that I got back to CIM and continued CRS deploying. But faced that can't deploy an app with name CRS because it already exists. So I added <arg value="--force" /> to ATG/CIM/plugins/Base/ant/cim-ant.xml in 865 line. Then all work fine.

    Good luck!

  • 4. Re: Error while trying to Initialize endeca project in CIM
    Jurii Banin Newbie
    Currently Being Moderated

    Hi everyone!

     

    I've found out that for some reason endeca config at %DYNAMO_HOME%\servers\[INSTANCE_NAME]\localconfig\atg\endeca\ApplicationConfiguration.properties was corrupted. Here is my current config, it might be helpful:

     

    workbenchPort=8006

    workbenchHostName=localhost

    baseApplicationName=CRS

     

     

     

    locales=en_US

    defaultLanguageForApplications=en

    keyToApplicationName=default=CRS

     

    Make sure that in this file you specified properties that were specified in CIM.

    Important! Check this config BEFORE initializing your Endeca application. Just exit CIM after DB and server instances configuration, check config file and then run CIM again and create your Endeca application (as described in CRS Installation and Configuration Guide).

     

    Cheers!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points