2 Replies Latest reply on Jul 8, 2013 11:15 PM by Mohamed DEV

    webutil error

    Mohamed DEV

      Hi to all

         DB: 11g r2

         OS: win7 32bit

         developer: 10g r2

      I run forms via java (jre-6u37-windows-i586.exe) instead of jinitiator,

      also I installed (jdk-1_5_0_09-windows-i586-p.exe),

      and when I sign the jars I use these steps :

      1 C:\Program Files\Java\jdk1.5.0_09\bin\jarsigner.exe

      2 C:\Program Files\Java\jdk1.5.0_09\bin C:\DevSuiteHome_1\forms\webutil\sign_webutil.bat


      3 C:\Program Files\Java\jdk1.5.0_09\bin C:\DevSuiteHome_1\forms\webutil\sign_webutil.bat


      And all jars are sign successfully.

      The problem is when I'm gonna run the form which has webutil in builder the following message appears:


      oracle.forms.webytil.file.FileFunctions been not found



      Any help will be appreciated .... thank you

        • 1. Re: webutil error
          Carlos Cortez

          Hello Mohamed,


          Welcome to Oracle's Forums!!


          Let's see, in first time frmwebutil.jar should not be signed.


          which jacob version are you using ??


          Previous to run the form, have you compiled the webutil.pll and generated webutil.plx file ??

          Ensure the webutil.pll and webutil.plx are in the FORMS_PATH variable.

          Ensure ORACLE_HOME\forms\server\default.env has append ORACLE_HOME\jdk\jre\lib\rt.jar to the CLASSPATH entry


          In the form you are running ensure the following:


          - Webutil.pll is added to the form.

          - In Forms Builder under edit -> preferences -> runtime ensure the "Application server url" is not empty, otherwise click on "reset to default"

          - Append "?config=webutil" at the end of your url, so you end up with a URL like:  http://server:port/forms/frmservlet/?config=webutil


          Hope this helps you




          • 2. Re: webutil error
            Mohamed DEV

            First of all ... Thank you for your interest


            I forgot to tell that this problem happens when I'm running the form in the builder (I haven't installed Application Server yet)

            another thing,this the first time I configure webutil.


            And about sign frmwebutil.jar I already signed it, so what can I do now? (I mean ,Is there  away to remove this sign or something like that?).

            And I don't know how can I know the version of jacob.jar ,also I got frm-91507 interanl error: unable to generate webutil.plx when I'm trying to compile the webutil.pll .. I have tried many solutions to solve this but nothing work.


            The last thing I didn't understand "Ensure ORACLE_HOME\forms\server\default.env has append ORACLE_HOME\jdk\jre\lib\rt.jar to the CLASSPATH entry"


            But this path "ORACLE_HOME\jdk\jre\lib\rt.jar" exists in CLASSPATH in default.env file


            And all the rest I already did, I know above more questions "so don't be from me " but I really wanna learn


            God bless you man