1 Reply Latest reply: Aug 5, 2013 1:12 AM by Hunter Li-Oracle RSS

    Configure-Software-Update-Libraries fails

    rosen

      So, during the initial install of EMOC 12.0.1.3 everything goes just fine until it starts configuring the software update libraries. The odd part about the error message it's giving me is that the MOS credentials are fine. EMOC can use the same credentials to activate an asset. So, what is causing this? I've dug through Oracle's docs and I can't find any references to this so I'm hoping someone with experience can guide me.

       

      Thanks!

      Job ID      : opscenter.9
      Job Name    : Configure All Software Updates
      Job Type    : Configure-Software-Update-Libraries
      Job Description    : -
      Run ID      : 2
      Status      : FAILED
      Mode        : Actual run
      Owner       xxxxxxxxx
      Create Date : 07/09/2013 03:06:42 PM EDT
      Start Date  : 07/10/2013 02:43:43 PM EDT
      Last Updated : 07/10/2013 02:47:34 PM EDT

      Execution Order : SEQUENTIAL

      Failure Policy  : ABORT_ON_ANY_FAILURE

       

       

      Task   : VirtImageLibraryCRUDTask
      Task Run ID : 2713
      Target : 172.17.11.231-EC
      Status : SUCCESS
      Result : Library created successfully from URL file:///var/opt/sun/xvm/locallib/swlib2 (62563)
      Logs   :
          07/10/2013 02:43:44 PM EDT INFO Library file:///var/opt/sun/xvm/locallib/swlib2 already exists on the system. (62203)

       

       

      Task   : VirtImageNormalizationTask
      Task Run ID : 2714
      Target : 172.17.11.231-EC
      Status : SUCCESS
      Result : Task completed successfully. (15029)
      Logs   :

       

       

      Task   : CreateFolderTask
      Task Run ID : 2715
      Target : 172.17.11.231-EC
      Status : SUCCESS
      Result : Task completed successfully. (15029)
      Logs   :
          07/10/2013 02:43:44 PM EDT INFO Number of times to attempt wait: 90
          07/10/2013 02:43:44 PM EDT INFO Library Status = FOLDER_EXISTS
          07/10/2013 02:43:44 PM EDT INFO Library is ready

       

       

      Task   : UCETask
      Task Run ID : 2721
      Target : SatelliteTarget->EC
      Status : FAILED
      Result : Task failed. (15030)
      Logs   :
          07/10/2013 02:43:44 PM EDT INFO Initializing Library Directory: /var/opt/sun/xvm/locallib/swlib2/8b0e3143-72cb-4e36-a49b-d5143d1eb2e8/data
          07/10/2013 02:44:14 PM EDT INFO No Update bundle specified.
          07/10/2013 02:47:34 PM EDT ERROR Software Update Service is not configured. Please verify MOS Credentials (35660)
        • 1. Re: Configure-Software-Update-Libraries fails
          Hunter Li-Oracle

          The log file /var/opt/sun/xvm/uce/opt/server/logs/error.log may give more details for the problem though it's not very readable. FYI, the problem I got was: I used a nfs file system to place the libraries, and somehow the configuration utility couldn't grab the file lock from the nfs file system. It worked before, but not for that time. I didn't figure out the reason, However, after I moved everything from the nfs file system to the local filesystem, the problem was resolved. Just FYI.