2 Replies Latest reply: Aug 22, 2013 2:39 PM by jchristian RSS

    Need help in Oracle OS Authentication

    user10839503

      I a using Solaris sparc 32 bit machine. It has Oracle10g installed.

       

      I am trying to connect to oracle database using os authentication.

      i have already setup os authentication in backend.I followed all the steps from this link http://docs.oracle.com/cd/B28359_01/java.111/b31224/clntsec.htm#CIHCBCBC

       

      OS authenticated user is ops$oracle.

       

      I have written following code to connect to database:-

       

      String url = "jdbc:oracle:thin:@oracleserver.mydomain.com:5521:dbja"

      Driver driver = new oracle.jdbc.OracleDriver();

      DriverManager.registerDriver(driver);

      Properties props = new Properties();

      props.setProperty(OracleConnection.CONNECTION_PROPERTY_THIN_VSESSION_OSUSER,"oracle");

      Connection conn = DriverManager.getConnection( url, props);

       

      when i run the above code using this driver, it gives error as "invalid username/password ; logon denied'

      using oci driver "no ocijdbc11 in java.library.path"

       

      for the 2nd error i kept libocijdbc11.so in the $ORACLE_HOME/lib32 and then tried and it says ::

       

      Exception in thread "main" java.lang.UnsatisfiedLinkError: /oracle/product/10.2.0/Db_1/lib32/libocijdbc11.so: ld.so.1: java: fatal: /oracle/product/10.2.0/Db_1/lib32/libocijdbc11.so: wrong ELF data format: ELFDATA2LSB (Possible cause: endianness mismatch)

       

      Please help me to resolve the issue...

      Thanks..