This discussion is archived
2 Replies Latest reply: Jul 12, 2013 3:52 AM by Rida RSS

udev disks not fully visible when installing Oracle Grid

Rida Newbie
Currently Being Moderated

Hi all,

I am in the process of installing Oracle database RAC 11gr2  on two RHEL 6.2 nodes.

I am using udev to manage the iscsi LUNs visible in both nodes.

 

I created the following rules in udev :

KERNEL=="sd*", BUS=="scsi", PROGRAM=="/sbin/scsi_id --whitelisted --replace-whitespace --device=/dev/$name",RESULT=="36006016042612e00a6ae6fea8ad2e211",NAME="oracleasm/data0", OWNER="grid" GROUP="asmadmin" MODE="0660"

KERNEL=="sd*", BUS=="scsi", PROGRAM=="/sbin/scsi_id --whitelisted --replace-whitespace --device=/dev/$name",RESULT=="36006016042612e00a8ae6fea8ad2e211",NAME="oracleasm/data1", OWNER="grid" GROUP="asmadmin" MODE="0660"

KERNEL=="sd*", BUS=="scsi", PROGRAM=="/sbin/scsi_id --whitelisted --replace-whitespace --device=/dev/$name",RESULT=="36006016042612e00aaae6fea8ad2e211",NAME="oracleasm/data2", OWNER="grid" GROUP="asmadmin" MODE="0660"

KERNEL=="sd*", BUS=="scsi", PROGRAM=="/sbin/scsi_id --whitelisted --replace-whitespace --device=/dev/$name",RESULT=="36006016042612e00acae6fea8ad2e211",NAME="oracleasm/data3", OWNER="grid" GROUP="asmadmin" MODE="0660"

KERNEL=="sd*", BUS=="scsi", PROGRAM=="/sbin/scsi_id --whitelisted --replace-whitespace --device=/dev/$name",RESULT=="36006016042612e00aeae6fea8ad2e211",NAME="oracleasm/data4", OWNER="grid" GROUP="asmadmin" MODE="0660"

Now when I begun installing Grid software , I came to a very annoying problem :  not all the disks set by udev are visible in the step of ASM diskgroup  creation : http://imgur.com/8okMaei

What is strange is that when I reload udev rules and restart it, some disk that was visible became unvisible in grid discovery and vice-versa.

 

I am blocked at this stage, your help is really appreciated!

 

Regards

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points