2 Replies Latest reply on Jul 18, 2013 1:36 PM by 742824

    Upgrade from 4.0.2 to 4.1.1 failed


      I was attempting to upgrade to 4.1.1.  The upgrade worked perfectly in my sandbox database but failed in the production database.  Servers and databases are the same versions.  I opened an SR with Oracle support, but we were unable to resolve the issues.  I needed a working production app so we reverted to 4.0.2.  Here are the highlights from the 6 hours I worked with support.


      Did OWC with the Customer.
      +++ Customer upgraded the existing Version of Apex i.e. 4.0 to 4.1.1.
      +++ The upgrade went well but the images directory is not getting updated.
      +++ There are 2 directories noticed on the Server with the names /i/ and /images/
      +++ Images directory is updated with the latest 4.1.1 images after execution of the script apxldimg.sql but the directory /i/ remained with the Apex 4.0 images.
      +++ Modified the images prefix for the Apex 4.1.1 to /images/
      +++ Apex Homepage is accessible but the application fails to load.
      +++ Customer decided to rollback to the older version 4.0
      +++ After executing the steps provided on the documentation, the Version is downgraded to 4.0, but the Registry Version remained with 4.1.

      Has anyone encountered this problem before?  If yes, how do I resolve it?  I would like to take advantage of fixes/new features, but we will not be upgrading until we have answers.  Any help would be appreciated.

      Thank you.



      Message was edited by: 742824 Oracle support believes the problem with the production upgrade is due to the fact that the image directory was created in a 10g database, then the database was upgraded to 11g.  The test database was a new 11g, not an upgraded 10g.  They recommend running apex_epg_config.sql instead of apxldimg.sql.  The upgrade has not yet been rescheduled.