11 Replies Latest reply: Jul 18, 2013 8:37 AM by 4d3cc372-ff22-4a68-8736-d113752a577e RSS

    OracleXE-Server-Install-Message: The 8081 port is in use.

    user7698480
      I've a problem installing in a Windows System Operational with MCAfee anti-virus.

      OracleXE-Server-Install-Message: The 8081 port is in use.

      I need to install Oracle XE in the silent mode.
        • 1. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
          clcarter

          >> The 8081 port is in use.

           

          Port conflict, you'll have to pick a different port number. 8080 is "the usual", out of the box default, to see which ports are in use try this in a command box:

           

          {code}

          netstat -an |findstr /i LIST
          ...
          # Proto  Local Address          Foreign Address        State
          ...
            TCP    0.0.0.0:80             0.0.0.0:0              LISTENING  # probably a web server ...
            TCP    0.0.0.0:8081           0.0.0.0:0              LISTENING  # there is the conflict
            TCP    n.n.n.n:139            0.0.0.0:0              LISTENING  # win netbios ... ?
          ...

          {code}

           

          Is there any particular reason for using 8081, does the host have tomcat or something similar running?

          • 2. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
            user7698480

            Hi clcarter,

             

            How can I change the port number in the silent mode installation of Oracle XE?

             

            I already had trying to change it in the response\OracleXE-install.iss file, but nothing happened.

             

            I'm using the following command to try install the Oracle XE:

            setup.exe /verbose /s /f1"C:\DISK1\response\OracleXE-install.iss" /f2"C:\DISK1\oracle_log.txt" /V"/l*v "C:\DISK1\oracle_msi_log.txt""

             

            Regards,

            Jener Garcia Menezes

            System Architect at Prosegur S/A

            • 3. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
              clcarter

              Edit your C:\DISK1\response\OracleXE-install.iss file.

              • 4. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                user7698480

                I already had changed the HTTPPort number in the OracleXE-install.iss file, but the installation error didn't stopped. OracleXE-Server-Install-Message: The 8081 port is in use.

                • 5. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                  clcarter

                  Ok ... as mentioned earlier, pick a different port

                   

                  Try 8090 if there is no 8090 in a `netstat ..` output. Or pick another one, i.e. 9090. Any port number other than one that is already being used. As a general guideline, stay above 1024, and the default 8080 is usually fine unless it conflicts with another service that is already using that port.

                  • 6. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                    user7698480

                    Hi clcarter,

                     

                    I'd tried all yours the suggestions ports, but occurs the same error. I don't know if there is a problem with silent installation mode when it tries to get the port number in the configuration file. Because all ports that I try use, the error is always about 8081 port. I checked in the netstat and only the 8081 port is used by McAfee.

                     

                    The ports used in the machine are:

                      TCP    0.0.0.0:25

                      TCP    0.0.0.0:80

                      TCP    0.0.0.0:135

                      TCP    0.0.0.0:443

                      TCP    0.0.0.0:445

                      TCP    0.0.0.0:990

                      TCP    0.0.0.0:1051

                      TCP    0.0.0.0:3389

                      TCP    0.0.0.0:8081

                      TCP    127.0.0.1:5152

                      TCP    127.0.0.1:5679

                      TCP    127.0.0.1:7438

                      TCP    172.1.3.158:139

                      TCP    192.168.56.1:139

                     

                    I already tried 8080,  8090, 9090, 8070... and the answer was always - The 8081 port is in use. This error is for any port that I try configure in the OracleXE-install.iss file.

                     

                    Best regards,

                    Jener

                    • 7. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                      clcarter

                      Verify that the setting in the response file is really in effect, i.e. in a cmd box ...

                       

                      findstr /i httpport "C:\DISK1\response\OracleXE-install.iss"

                      ...

                      HTTPPort=8081

                      ...

                       

                      If your trying different things, getting the same result, perhaps the different part is really not so different ...

                      • 8. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                        user7698480

                        Hi clcarter,

                         

                        Following bellow the answer about the HTTPPort in the file.

                         

                        C:\DISK1>findstr /i httpport "C:\DISK1\response\OracleXE-install.iss"

                        **  HTTPPort - Provide any valid available port number

                              **

                        HTTPPort=9090

                         

                        As you can see, I think it is a setup.exe problem when running in silent mode.

                         

                        Have you any idea? If you can, please, try it with 8081 port in use...

                        The silent mode command is:

                        setup.exe /verbose /s /f1"C:\DISK1\response\OracleXE-install.iss" /f2"C:\DISK1\oracle_log.txt" /V"/l*v "C:\DISK1\oracle_msi_log.txt""

                         

                        Have you had another command about the installation in silent mode? The problem is that I can't change 8081 anti-virus port in all machines in the company through the world.

                         

                        Thanks a lot,

                        Jener

                        • 9. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                          4d3cc372-ff22-4a68-8736-d113752a577e

                          Would like to add.. I'm having the exact same problem.

                           

                          No matter what port is specified in the answer file, the silent install always complains about port 8081 (Used by McAffee here too).

                           

                          A manual setup makes no mention of port 8081, and does not complain about it.

                           

                          So, how do we get past this?

                          • 10. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                            clcarter

                            Yes it appears a silent install does not use the port specification in the setup file.

                             

                            Only possible work around that I can think of is disable the service that uses 8081 to free up that port. But that also makes the silent install less automatic, not really a good answer at all.

                            • 11. Re: OracleXE-Server-Install-Message: The 8081 port is in use.
                              4d3cc372-ff22-4a68-8736-d113752a577e

                              Is there a procedure to have this looked at ? Its seriously hapering our roll out of this product.

                               

                              The silent install will work if we turn off McAffee (port 8081), but this really is not the sort of thing that can be done.