1 Reply Latest reply: Jul 18, 2013 10:20 AM by Roberto Barrera RSS

    Server in RUNNING state but failed to start

    user6954356

      Hello everyone,

      I create a domain using WLST and then I start the AdminServer (WLS 12.1.1, Java 7 Update 21). I have done this in several physical servers and experienced no problem. Now I am experiencing the following problem in one of the physical servers-

       

      [java] WLST-WLS-1373540287870: <Jul 11, 2013 12:58:20 PM CEST> <Notice> <Server> <BEA-002613> <Channel "DefaultSecure" is now listening on 10.45.333.27:7800 for protocols iiops, t3s, ldaps, https.>

       

      [java] WLST-WLS-1373540287870: <Jul 11, 2013 12:58:20 PM CEST> <Notice> <WebLogicServer> <BEA-000329> <Started the WebLogic Server Administration Server "AdminServerSim" for domain "xpt" running in production mode.>

       

      [java] WLST-WLS-1373540287870: <Jul 11, 2013 12:58:20 PM CEST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RUNNING.>

       

      [java] WLST-WLS-1373540287870: <Jul 11, 2013 12:58:20 PM CEST> <Notice> <WebLogicServer> <BEA-000360> <The server started in RUNNING mode.>

       

      [java] ......................................................Could not connect to the server to verify that it has started. The error returned is: javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3s://myhost:7800: Destination unreachable; nested exception is:

       

      [java] javax.net.ssl.SSLHandshakeException: General SSLEngine problem; No available router to destination]

       

      [java] No stack trace available.

       

      [java] WLST-WLS-1373540287870: IOException when running WLSTProcess

           [java]    javax.net.ssl.SSLHandshakeException: General SSLEngine problem; No available router to destination]

           [java] No stack trace available.

           [java] WLST-WLS-1373540287870: IOException when running WLSTProcess

           [java] java.io.IOException: Stream closed

           [java]    at java.io.BufferedInputStream.getBufIfOpen(BufferedInputStream.java:162)

           [java]    at java.io.BufferedInputStream.read1(BufferedInputStream.java:272)

           [java]    at java.io.BufferedInputStream.read(BufferedInputStream.java:334)

           [java]    at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:283)

           [java]    at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:325)

           [java]    at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:177)

           [java]    at java.io.InputStreamReader.read(InputStreamReader.java:184)

           [java]    at java.io.BufferedReader.fill(BufferedReader.java:154)

           [java]    at java.io.BufferedReader.readLine(BufferedReader.java:317)

           [java]    at java.io.BufferedReader.readLine(BufferedReader.java:382)

           [java]    at weblogic.management.scripting.utils.WLSTProcess.run(WLSTProcess.java:78)

           [java]    at java.lang.Thread.run(Thread.java:722)

           [java] WLST-WLS-1373540287870: Stopped draining WLST-WLS-1373540287870

           [java] 

           [java] Problem invoking WLST - Traceback (innermost last):

           [java]   File "/updateDomain.py", line 22, in ?

           [java]   File "<iostream>", line 462, in startServer

           [java]   File "<iostream>", line 648, in raiseWLSTException

           [java] WLSTException: Error occured while performing startServer : Could not start the server, the process might have timed out or there is an Error starting the server. Please refer to the log files for more details.

           [java]

           [java] Java Result: 1

       
      So the server suceeds to go into RUNNING mode but the WLST startServer command fails to start the server. I went through all logs and compared them to successful instalations and found no difference. Does anyone have a clue about what might cause this problem or how I can I start the server using WLST in a trace mode so I get more information about what is going on?

       

      Thanks

      Paul