4 Replies Latest reply: Jul 19, 2013 1:12 AM by landyman RSS

    6.4 install media will not boot via USB


      Hi all,


      This is the process I've followed over and over with a few USB drives. Running OSX 10.8, burning to USB to install on my home PC for some development.


      minimac:~ kevin$ md5 oracle-linux-6.4.iso

      MD5 (oracle-linux-6.4.iso) = 744fc1663519b4d54da1345669fcee52

      minimac:~ kevin$ sudo dd if=oracle-linux-6.4.iso of=/dev/disk2


      7269460+0 records in

      7269460+0 records out

      3721963520 bytes transferred in 982.643618 secs (3787704 bytes/sec)

      minimac:~ kevin$ diskutil eject /dev/disk2

      Disk /dev/disk2 ejected


      Just will not boot from this image. I can boot from the "boot" ISO that has been copied to USB in the exact same manner. I even tried to convert the ISO to an IMG with hdiutil and still no boot. I'm re-downloading the 6.3 ISO because I know that worked in the past. Wondering if others are experiencing the same issue.

        • 1. Re: 6.4 install media will not boot via USB

          The Mac does not support PC BIOS booting. Support for the Mac hardware will also be limited. If you want to dual boot you will need to install Apple Bootcamp or using a 3rd party utility like rEFIt - An EFI Boot Menu and Toolkit


          But why bother? You can simply install and use free Oracle VirtualBox . I have it running on a Mac Pro, with over 100 virtual machines installed for testing and development, of course not all running at the same time. In VirtualBox simply select the ISO boot/installation image to install the OS. I cannot image working any other way.


          Since you can use VT-x hardware virtualization this is not going to slow things down too much, maybe 10 % (guessing) - it is a very different experience compared to old fashioned emulator software, which was converting CPU instructions, like Virtual PC for the Mac 68x and PowerPC architecture. I think it really does not make sense trying to hack your system to run Linux or any other OS. It will just keep you busy for no good reason and the result will most likely disappoint you.

          • 2. Re: 6.4 install media will not boot via USB

            Sorry I should have been more explicit... I'm creating the USB on my Mac. I'm attempting to boot on my PC, which is NOT a Mac.

            • 3. Re: 6.4 install media will not boot via USB

              I suggest to verify the ISO image integrity:


              On the Mac, open the Terminal app and type:


              openssl sha1 path_to.iso

              It should show 4ECB72ADE0186AFE2F95FFC8273FC146E177E2F9. If it does not that is the reason why it does not work because your download is corrupted.

              When you burn the DVD, no need to use dd. Open the Disk Utility application, and drag the iso file into the left side of the utility, then select the iso and click the Burn button. Make sure you select the iso file and not the mounted volume in case you opened it.


              If the above checks out ok and it still does not work, check your PC BIOS on your installation target and verify USB is selected as a boot device.

              • 4. Re: 6.4 install media will not boot via USB

                I did check the integrity (md5 sum is posted above). I downloaded the 6.3 ISO and the same problem occurred. As a test, I downloaded the CentOS 6.4 live dvd iso and burned it to the same USB using the same process (dd if=centos.iso of=/dev/disk2 bs=1m) and it worked. So, out with OEL for now. what a mystery - but thanks for responding.