5 Replies Latest reply on Jul 20, 2013 6:44 PM by user5940063

    ORA-06413: Connection not open


      I running Oracle in a x64 machine with windows 7

      I am trying to connect to a server of x64 but I am getting this error:

      Fatal NI connect error 6413, connecting to:
      (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=server)(PORT=1521)))(CONNECT_DATA=(SID=CRONUS)(CID=(PROGRAM=C:\Program Files (x86)\Common Files\Microsoft Shared\DevServer\9.0\WebDev.WebServer.EXE)(HOST=SEDNA)(USER=x))))

      I am trying to run my application in visual studio 2008 in debug mode.

      I guess the problem might be the special characters. Is there any solution for this without uninstalling and change the directory?

      Thank in advance.
        • 1. Re: ORA-06413: Connection not open
          the 6413 error is commonly caused when a directory containing brackets is used - like in your case (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=server)(PORT=1521)))(CONNECT_DATA=(SID=CRONUS)(CID=(PROGRAM=C:\Program Files (x86)\Common Files\Microsoft Shared\DevServer\9.0\WebDev.WebServer.EXE)(HOST=SEDNA)(USER=x))))
          where the CID contains C:\Program Files (x86).

          Not sure which OCI/Client release you are using, but in general the latest releases should contain this fix.
          Not sure as i haven't tried it, but maybe a link for the executable might solve the issue as well.
          If nothing works for your case, then yes, you have to reinstall.

          Edited by: kgronau on Mar 21, 2011 2:10 PM

          Have a look also at "My Oracle Support" note:
          Connecting to Oracle from Within Visual Studio Fails With: ORA-12154 or ORA-6413, While Compiled Applications Run Fine (Doc ID 334968.1)
          • 2. Re: ORA-06413: Connection not open
            How did you fix your problem I am stuck as well.
            • 3. Re: ORA-06413: Connection not open
              here is a trick that worked for me...

              The problem is the brackets in "Program Files (x86)"
              • 4. Re: ORA-06413: Connection not open

                I also facing this problem ..


                I have window 8 pro 64 bits and oracle 11g R2 64 bits.

                When I try to connect through Toad 32 bits run as Administration


                "ORA:06413: Connection not open "  message is pop up ..


                please help



                • 5. Re: ORA-06413: Connection not open

                  The executable module of your application has been placed into folder "C:\Program Files (x86)\..." while Oracle does not allow bracket symbols in client application. This could be very possible reason of the error mentioned in yout post. Try to re-install the application into another location that does not contain brackets in the path.




                  Migration and synchronization for all popular database formats