10 Replies Latest reply: Jul 24, 2013 2:55 AM by user12173797 RSS

    forms and reports server 11gr2 doesnt show portuguese characters

    user12173797

      Hello,

       

      I just installed oracle forms and reports 11gr2 (11.1.2.1.0), it runs over weblogic 11.3.6 , with jdk 1.7 and on the oracle enterprise linux 5.5. So far so good i was able to install sucesfully the forms and reports server for deployment. The proble arises when i try to run a form with special portuguese characters like à ã or ê they wont show up on the webform, or they show with a ? in place. I tried to change the nls_language variable but still no luck. anyone got ideas on how can i display sucessfully portuguese charactes.

       

      Thanks and i hope u can provide me some help here.

       

      PS: tried metalink but i coudnt see any threads similar to my problem.

        • 1. Re: forms and reports server 11gr2 doesnt show portuguese characters
          Paul M.
          I tried to change the nls_language variable

          How did you do it ? Please post the exact command(s)/configuration(s) you did.

          • 2. Re: forms and reports server 11gr2 doesnt show portuguese characters
            user12173797

            I added the NLS_LANG variable on the .bash_profile of the oracle user putting:

             

               NLS_LANG=PORTUGUESE.PORTUGAL.WE8ISO8859P1

             

            this didnt work, when i opened forms builder (frmbld.sh) the menus were still in english.

             

            Then i also added to the default.env environement file using the same line above but no luck.

             

            When i run the form on my developer environement wich is windows 7 pt (Portuguese) everything seems ok. The problem is when the forms are deployed to to the production server where the forms are deployied.

             

            this might be a font problem but i dont know where to change.

            • 3. Re: forms and reports server 11gr2 doesnt show portuguese characters
              Paul M.

              I added the NLS_LANG variable onthe .bash_profile of the oracle user putting:

               

                 NLS_LANG=PORTUGUESE.PORTUGAL.WE8ISO8859P1

               

              Did you export it ? Did you restart Forms server after that ?

               

              Also, how is LANG environment variable set for oracle user ?

              • 4. Re: forms and reports server 11gr2 doesnt show portuguese characters
                user12173797

                Hi Paul,

                 

                I dont have LANG variable set. i just have NLS_LANG i did exporty yes the NLS_LANG, doing export NLS_LANG=..... I did restart forms and reports server.

                 

                In my developer where things work, environement NS_LANG is set to PORTUGUESE_PORTUGAL.WE8MSWIN1252.

                 

                Default.env is the default one that comes out the instalation with just one added line NLS_LANG= ...

                 

                Formsweb.cfg  has the usual configuration sections that i use to run aplications. form=, width=, height= the base html is the baseHTMLjpi.htm wich i think its the default one, the env file i am using is the default.env one.

                • 5. Re: forms and reports server 11gr2 doesnt show portuguese characters
                  Paul M.

                  I dont have LANG variable set.

                  As oracle user execute

                  $ locale

                  What do you get ?



                  BTW, in your previous post you did mention NLS_LANG=PORTUGUESE.PORTUGAL.WE8ISO8859P1 : I think the first dot is a typo, it should be underscore.


                  Also, what's the character set of your database ?

                  • 6. Re: forms and reports server 11gr2 doesnt show portuguese characters
                    user12173797

                    I remember when i installed forms and reports and also weblogic on top of those my system locale was english i didnt change it to portuguese  before installing it and maybe thats the problem. I only changed to portuguese after installing forms and reports. So my system locale is now pt_PT.UTF-8 but it wasnt this one when i instaled it was the default english one.

                     

                     

                    for the database i am using:

                     

                    NLS_CHARACTERSET               WE8ISO8859P1

                    NLS_NCHAR_CHARACTERSET         AL16UTF16

                     

                    The problem right now is the static characters written on the forms, doesnt mean i wont have same problem with tables. but right now my problem is with static independent database fields on the forms.

                     

                    yep its a typo. :-)

                     

                    Update: Meanwhile i did an instalation of the product on Portuguese locale and the result was the same. the static portuguese characters wont show up.

                    • 7. Re: forms and reports server 11gr2 doesnt show portuguese characters
                      Roberto Barrera G

                      Hi,

                       

                      NLS_LANG can co in the default.env file, .bash_profile or .profile or your user, as well try to put it in the startup paramether of your WebLogic server.


                      For Reports try to modify the reports.sh file that you can find in the instance directory.


                      Greetings

                      • 8. Re: forms and reports server 11gr2 doesnt show portuguese characters
                        user12173797

                        Hi all,

                         

                        It was my mistake, when i transfered the files to the AS they got corrupted, because someone used forms upgrade asssintat on forms that were already 10g and that caused the problem. Anyway Thanks to all you guys that tried to help but this was a false alarm and its not even a bug of forms it was a mistake,

                         

                        Greetings

                        • 9. Re: forms and reports server 11gr2 doesnt show portuguese characters
                          ultrayoYO

                          Hi all

                           

                          I got the same error but am use THAI language. When start Oracle Forms Builder on OS Linux Rehat 6.3 64bit can't show THAI language.  I try to export NLS_LANG=THAI_THAILAND.TH8TISASCII is show error "frm-91111 ??????????-?????? frm-10039  ???????".   Do you know how to fix this cause.

                          Please kidnly to suggestion to me. 

                           

                          Thank you very much.

                          Yo

                          • 10. Re: forms and reports server 11gr2 doesnt show portuguese characters
                            user12173797

                            Hi,

                             

                            The problem that hapened with us, was that we were using forms 10g (already in 10g) and we run Forms migration Assistant and it corrupted the .fmb files, when the fmb were compiled to our Aplication server the strange characters were brought. Before knowing that i tried everything i put the NLS_LANG but it didnt work.

                             

                            Try doing this, do a complete new form using 11g forms builder and write something in Thai put a lot of characters that u know they wont show up normally and check if it runs in our Apliation server, my clue is that they will run withouth a problem and the problem is in your forms.

                             

                            Another question what version of the forms u were using before migrating to 11g , 6i, 9i, 10g?

                             

                            I would 1st try this. There is someone that posted here that said character set can be configured in weblogic server itself i dont know how to do this.

                             

                            kind regards,

                            Paulo